WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
Single page breadcrumbs shows random post navigation (8 posts)

  1. Sofusalbertsen
    Member
    Posted 12 months ago #

    I have a webshop with categories, sub, and pages
    The breadcrumbs are fine in categories, their subs, but in single-product pages, the breadcrumbs are alle pointing at a single post, that has nothing to do with the products.
    What can be wrong here?

    Eg. for subcat breadcrumbs are:
    Hjem / Bestilling af materiale / Piktogrammer og skilte
    But for a single product (eg. alarm) it is:
    Hjem / Nyheder / Studierejse med autocamper
    Nyheder being a category.

    -Sofus

    http://wordpress.org/plugins/woocommerce/

  2. Roy Ho
    Member
    Posted 12 months ago #

    And are you sure the breadcrumbs are generated by WooCommerce? Sometimes themes have their own breadcrumbs...

  3. Sofusalbertsen
    Member
    Posted 11 months ago #

    Yes, quite sure, as the HTML is the following:

    <nav class="woocommerce-breadcrumb" itemprop="breadcrumb">

    Can i give other information to you regarding the page, or can you guide me to where i could look for the problem?

    Thanks
    -Sofus

  4. Sofusalbertsen
    Member
    Posted 11 months ago #

    Bump.
    Smashing, any ideas?

  5. Roy Ho
    Member
    Posted 11 months ago #

    That HTML doesn't tell me if it is from WC or not as themes/plugins can filter that...

    To know for sure, switch to 2012 theme and re-test.

  6. Sofusalbertsen
    Member
    Posted 11 months ago #

    Changed back, and you are right, it's the theme that does it.
    Any quick fix on that, or is it the theme makers i should talk to there?

  7. Roy Ho
    Member
    Posted 11 months ago #

    Yes you should talk to the theme developers about this.

  8. cerstrand_mace
    Member
    Posted 10 months ago #

    I had the same issue. The thing I did wrong was that I had put the breadcrumb call function outside the product loop. I put it inside and the problem was solved.

Reply

You must log in to post.

About this Plugin

About this Topic