WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Since upgrading "Unable to locate the main framework files" (7 posts)

  1. dadalab
    Member
    Posted 2 years ago #

    Running Pagelines with a child theme "Baseline" that was working fine prior to upgrade. Now all pages on site have this text running across top:
    Unable to locate the main framework files! Make sure the parent theme folder is named correctly.

    I think the issue is in my setup.php which includes that reference but not sure what to change

    /**
     * REQUIRE THE FRAMEWORK FILES
     * --- This is some checking, and you should not have to touch this code (unless directed) ---
     * 3.4 compat added
     */
    
    if ( function_exists( 'wp_get_theme' ) ) {
    	$parent_folder = wp_get_theme( basename( __DIR__ ) )->get( 'Template' );
    } else {
    	$theme_data = get_theme_data(STYLESHEETPATH . '/style.css');
    	$parent_folder = $theme_data['Template'];
    }
    $init_file = WP_CONTENT_DIR .'/themes/' . $parent_folder . '/functions.php';
    
    if ( file_exists( $init_file ) )
    	require_once( $init_file );
    else
    	add_action( 'template_redirect', create_function( '', 'echo "<p>Unable to locate the main framework files! Make sure the parent theme folder is named correctly.</p>";' ) );
  2. Arie Putranto
    Member
    Posted 2 years ago #

    That is the Theme problem, have you contact the theme developer?

  3. dadalab
    Member
    Posted 2 years ago #

    Thank you. I checked the Pagelines site and if I understood correctly it sounded like one of my options is to not use the child theme.
    I removed the child theme and the error went away but so did my customizations.
    How I can avoid having to manually initiate all those customizations to the Pagelines templates, text boxes and box sets?

  4. Simon Prosser
    Theme Review Admin
    Posted 2 years ago #

    In the child theme, replace setup.php with the contents here: http://paste.pagelines.com/3kq

  5. dadalab
    Member
    Posted 2 years ago #

    That worked. Thank you for the post.

  6. dadalab
    Member
    Posted 2 years ago #

    Resolved.

  7. kinloch
    Member
    Posted 2 years ago #

    Worked for me too -- thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic