WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce SagePay Direct Payment Gateway
[resolved] Simulator Return Error (9 posts)

  1. underclass
    Member
    Posted 1 year ago #

    Hello
    In simulator mode I receive the following message

    INVALID -

    I am assuming this is part of the 4020 err for invalid ip addresses, should the simulator mode display the invalid ip?

    Thanks

    http://wordpress.org/extend/plugins/sagepay-direct-for-woocommerce-payment-gateway/

  2. swicks
    Member
    Plugin Author

    Posted 1 year ago #

    Hi

    Apologies I've only just picked this up. Yes it is suppose to return the complete error message after INVALID (which contains the invalid IP). This is fixed in the next release. Thanks for letting me know.

    Regards

    Steve

  3. swicks
    Member
    Plugin Author

    Posted 1 year ago #

    Fixed in next release

  4. kapitaine
    Member
    Posted 1 year ago #

    Hi Swicks, first of all, thanks for the plugin, looks to be great!

    However, I too am also getting this error in version 0.1.5 when I go to checkout on a product.

    When you say it will be fixed in the next release, do you mean a version after this? And if so, when do you think? (sorry for the pressure!).

    Also, how do I configure my test SagePay account with your plugin? Is it really only the 'Vendor Name' that is required in the settings or is there a place to put my password?

    Thanks,
    Mikey

  5. swicks
    Member
    Plugin Author

    Posted 1 year ago #

    Hi
    The fix is only to return the ip address your using So I wasn't too concerned in the update. You need to setup a SagePay account giving u a simulator account with vendor name - setup your ISP IP address in your SagePay simulator screen. Set direct to simulator, you don't need a password.
    Regards Steve

  6. kapitaine
    Member
    Posted 1 year ago #

    Hi

    It's odd, because no matter what, I always get the "INVALID -" message.

    I have specified my IP in the SagePay simulator account along with the IP of the server the website is hosted on.

    They say the following:

    If you have sent badly formatted or incorrect data in any of the fields you'll receive an INVALID message with an explanation of the error in the StatusDetail field.

    If everything is formatted correctly and is validated successfully an OK response will be returned to your server with a redirectURL to which your code should send the user. This will present you with another Simulator page from which you can simulate Server Notification POSTs.

    However, all data I am sending seems to be just fine and checks out. I'm not however, sending this via HTTPS, but rather standard HTTP - could that cause this or should I be able to test this way?

    Many thanks,
    Michael.

  7. swicks
    Member
    Plugin Author

    Posted 1 year ago #

    Hi
    If you are using 0.1.5 - add these 4 lines of code before return $response_status on line 835.

    else
                {
                    return $response_statusdetail;
                }

    This should now display the IP address Sagepay thinks you are hosted on.

    regards,

    Steve

  8. swicks
    Member
    Plugin Author

    Posted 1 year ago #

    In simulator mode you can use HTTP - the message back should now look like:

    INVALID - The IP address of the server sending the transaction does not match the valid IP address ranges listed in the Simulator. The IP address Simulator sees for your server is 149.127.120.232. You can add this IP in the Accounts section of Simulator if you wish.

  9. kapitaine
    Member
    Posted 1 year ago #

    Hello Swicks!

    Just wanted to let you know that this did the trick. Perfect. Thank you very much again for your hard work.

    I got the proper error back, add the correct IP (as shown by the new error from your plugin) to the simulator with SagePay, and now it works as expected.

    It's great you're offering this plugin for free, but if it helps to make the updates / bug fixes better, maybe consider charging a small fee? I'd gladly pay and I'm sure others would too.

    Thanks again!
    Mikey.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.