WordPress.org

Ready to get started?Download WordPress

Forums

Genesis Simple Sidebars
[resolved] Simple Sidebars 2.0.0 and Genesis 2.0.1 Category Issue (21 posts)

  1. blogprofis
    Member
    Posted 11 months ago #

    Hi,

    since updating to Genesis 2.0.1 and Simple Sidebars 2.0.0 the correlation category -> sidebar option/select sidebar doesnt work any more. So even if i choose a specific sidebar there, within the category archives of that category the main sidebar appears. Did work before with Genesis 1.9 and Simple Sidebars 1.0.0./0.9.1

    I tried with Genesis 2.0.1 and Simple Sidebars 0.9.1, but than if you choose a sidenar within category options and saving, it doesnt save that value.

    Do you have any idea or solution? Thanks a lot

    http://wordpress.org/plugins/genesis-simple-sidebars/

  2. Vinnee
    Member
    Posted 11 months ago #

    Have the same issue...so close! Works when you identify per post, but per category would be really awesome. Hope there's a fix.

  3. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 11 months ago #

    What child themes are you using?

  4. Vinnee
    Member
    Posted 11 months ago #

    Using Executive. I can send the site via twitter pm.

    Thanks

  5. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 11 months ago #

    I tried Simple Sidebars 1.0.0 with Executive & it worked as expected in my install.

  6. Vinnee
    Member
    Posted 11 months ago #

    Worked at first, but then reverts back to losing the association with the sidebar via category selection. I'll look into this a little more.

  7. scallemang
    Member
    Posted 11 months ago #

    Not trying to derail someone else's thread (having already gotten helpful advice from Ron this weekend!); just noting that I am having the same issue using News - category sidebars revert to Default upon saving. I'll similarly see if some plugin conflict reveals itself and will post here if it does.

  8. bram-ee
    Member
    Posted 11 months ago #

    I can confirm having the same issue. Balance Theme 1.0, Genesis 2.0.1. Sidebars revert to default. Looking forward to a solution.

  9. blogprofis
    Member
    Posted 11 months ago #

    I use associate theme.

    @Ron: neither 1.0.0 nor 2.0.0 works with genesis 2.0.1. when it comes to category-driven-sidebar. Switched off all other plugins, but didn't help.

  10. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 11 months ago #

    I've tested Executive, Associate, Balance & News with Genesis 2.0.1. Simple Sidebars worked with all of them.

    If you switched themes you need to go to the widgets area and add your widgets back to your custom sidebars.

    If you are running a caching plugin you need to flush the cache (and possibly deactivate as well) to see the changes.

    If you are running custom code in your child theme functions file save a copy and restore the default functions file for your theme. Then add back your customizations one at a time to see if you can find a customization that is affecting the sidebar.

  11. bram-ee
    Member
    Posted 11 months ago #

    Hi Ron,

    Re-added themes, widget etc with no result. All plugins disabled. No caching. Cleared functions.php. Still no result. The category doesn't seem to accept any sidebars...

  12. blogprofis
    Member
    Posted 11 months ago #

    same problem. And: it worked on the same blog/same constellation BEFORE i updated to Genesis 2.0.1. I didn't change anything else. Maybe its not a problem with your Plugin, but with genesis. But it exists.

    Thanks anyway.

  13. bram-ee
    Member
    Posted 11 months ago #

    Maybe useful to add: custom sidebars I made and assigned to certain pages before I updated to genesis 2.0.0 are still visible somehow. However reselecting them from the SS menu later on makes them disappear.

  14. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 11 months ago #

    There is an update coming to simple sidebars for changing your sidebar selection in the category/tag edit screen. Existing selections should all be working fine (per my post above).

  15. bram-ee
    Member
    Posted 11 months ago #

    Update fixed the issue for me. Categories now accept custom sidgebars assigned to them and don't jump back to default.

    Ron, thanks for fixing this on such short notice!

  16. scallemang
    Member
    Posted 11 months ago #

    That's awesome, Ron; to echo bram-ee, the speed of your responsiveness and quality of your solutions is commendable - the category sidebars will be terrifically useful.

  17. Vinnee
    Member
    Posted 11 months ago #

    Saaawwweeeet! Yes, works for me...like a charm.

    Thanks Ron!

  18. boulderbrian
    Member
    Posted 10 months ago #

    Ron is there any way to have a post automatically use the same sidebar as it's parent category?

  19. blogprofis
    Member
    Posted 10 months ago #

    Works great, thanks a lot Ron!

  20. jjohns
    Member
    Posted 10 months ago #

    I'm still having this problem Ron. I've tried creating new categories and then new sidebars, flushing cache, checking out functions, but nothing makes the sidebar stick for categories.

  21. csbecker
    Member
    Posted 5 months ago #

    I'm also still having this issue. Followed all steps of clearing cache etc. I'm using Agency.

    A blog entry in the category Blog that is assigned the blog sidebar:
    http://www.acquireb2b.com/blog/marketing-or-lead-gen

    A blog entry in the same category but assigned the blog sidebar uniquely on the post through the editor:
    http://www.acquireb2b.com/blog/marketing-automation-pros-and-amateurs

    I would appreciate any assistance.
    Chris

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.