WordPress.org

Ready to get started?Download WordPress

Forums

Silly Question (5 posts)

  1. onekea
    Member
    Posted 3 years ago #

    So I'm building a template for a client of mine and there is a flash movie in place as the main image. Now I adjusted all the other images in the site to reference the correct coding, but for the flash file I cannot get it to display correctly.

    I tried just linking the file directly but that didn't work either.

    <script type="text/javascript">
    AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0','width','693','height','269','title','main Banner','src','http://www.ashburnwineshop.com/wp-content/themes/wineshop/images/mainbanner.swf','quality','high','pluginspage','http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash','movie','http://www.ashburnwineshop.com/wp-content/themes/wineshop/images/mainbanner.swf' ); //end AC code
    </script><noscript><object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0" width="693" height="269" title="main Banner">
    <param name="movie" value="http://www.ashburnwineshop.com/wp-content/themes/wineshop/images/mainbanner.swf" />
    <param name="quality" value="high" />
    <embed src="http://www.ashburnwineshop.com/wp-content/themes/wineshop/images/mainbanner.swf" quality="high" pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" width="693" height="269"></embed>
    </object></noscript>

    I've got a couple other sites that I use this with and I have been unsuccessful in getting this to work. Any suggestions?

  2. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 3 years ago #

    Are you putting this into the page/post content or in one of the theme .php files?

  3. ClaytonJames
    Member
    Posted 3 years ago #

    Start with the path to the script. It currently 404's.

    GET AC_RunActiveContent.js
    //www.ashburnwineshop.com/Scripts/AC_RunActiveContent.js
    404 Not Found

    This works okay...

    <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0" width="693" height="269" title="main Banner">
    <param name="movie" value="http://www.ashburnwineshop.com/wp-content/themes/wineshop/images/mainbanner.swf" />
    <param name="quality" value="high" />
    <embed src="http://www.ashburnwineshop.com/wp-content/themes/wineshop/images/mainbanner.swf" quality="high" pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" width="693" height="269"></embed>
    </object>

    Just not the active content script.

  4. onekea
    Member
    Posted 3 years ago #

    I was putting it in the theme files. Is there an alternative?

    Ok great, now my server says i don't have permission to upload files... yay... now I cant even try this. Thanks for the tips though!!

  5. ClaytonJames
    Member
    Posted 3 years ago #

    Putting it in your theme directory is fine as long as you call the script from that location. What I pasted above indicates that the script is being called from here: //www.ashburnwineshop.com/Scripts/AC_RunActiveContent.js

    - not here: //www.ashburnwineshop.com/wp-content/themes/your_theme_name/AC_RunActiveContent.js

    Either the location of the file, or the path pointing to it, needs to be changed.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.