WordPress.org

Ready to get started?Download WordPress

Forums

TinyMCE Advanced
Significant downgrade in capability (2 posts)

1 star
  1. TheWatcher2
    Member
    Posted 4 months ago #

    The latest version of TinyMCE eliminates features that most people use for routine production of web site content. Since WordPress has locked themselves into this program, it has dragged WP down with it, too. The elimination of simple image editing options forces users of WP to do their own coding for each image placed on a page or post. This has made WP v3.9 a disaster for most users that just want to get work done, not code their own pages. The plugin author and WP developers have put out a new product with no thought to obtaining feedback from actual users. Failure to get true "voice of customer" data when developing a product has resulted in many infamous failures in the market, even for the largest of companies (think, New Coke). I hope that WP and the author of this plugin (and TinyMCE) hear the tremendous negative response to WP 3.9 and quickly correct these problems. The frustration level grows daily for those of us who simply want to get work done as fast as possible.

  2. Reinhold667
    Member
    Posted 4 months ago #

    this ^^

    Seriously, i wait for updates every day now since writing new posts is almost a pain. Have to work much longer now on something than before.

    The changes and removal of features is the most stupid thing since a long while in the wordpress world.

    The incompability between plugins and bugs since 3.9 is phenomenal bad.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.