WordPress.org

Ready to get started?Download WordPress

Forums

Sight theme - slideshow and font issues (19 posts)

  1. josiahemsley
    Member
    Posted 3 years ago #

    Hi,
    this is my first post, hopefully I can offer some know how myself soon.

    I recently installed WP, and a theme from WPshower called Sight.
    I am quite early on with my modifications of this theme, but already have an issue -
    My slideshow is broken and will not display more than 1 post.

    I have looked through all the comments on WPShowers site, and many other people have the same issue, however, they have fixed the problem by renaming the jquery.cookie.... to jquery.cooki.... Perhaps someone is familiar with this method...

    If someone could peak a look at my code and give me a clue of what to alter i would be very grateful!

    Also, very dumb, but i cannot find the right line to change the Serif fonts... i have changed all fonts i can see in the style.css.

    thank you in advance.
    josiah
    http://www.josiahemsley.com/wordpress

  2. lockettpots
    Member
    Posted 3 years ago #

    Re the fonts

    In your body css you have
    font: "Trebuchet MS", Arial, Helvetica, sans-serif,;

    The correct form is

    font-family: "Trebuchet MS", Arial, Helvetica, sans-serif;

    Notice there is no comma after sans-serif

  3. lockettpots
    Member
    Posted 3 years ago #

    Have a look inside your
    http://www.josiahemsley.com/wordpress/wp-content/themes/sighttheme/js/ folder

    is there a file called jquery.cookie.js? If there is rename it to jquery.cooki.js

    I'm not familiar with the Sight theme but from what you said in your post this may be the case

  4. josiahemsley
    Member
    Posted 3 years ago #

    Ah, thanks for pointing that out!

    I have tried changing the name of the cookie.js - but this did not work for me. Could it be another problem, or am i most likely just doing it wrong... I will try again either way

    thanks

  5. satishmk
    Member
    Posted 3 years ago #

    Was my Sight Theme working wel i dono why suddenly stoped moving slide..

    but same theme i use in my other domain just to test the theme but there it working.....am Not getting wts the exact problem.....

    Problem wit :http://NammaGulbarga.com

    But, Working here: http://hibsol.com

  6. carlosjesus
    Member
    Posted 3 years ago #

    Hi,

    I have a clean installation of Sight but the slideshow isn't appearing.

    I created 2 posts with featured image and clicked in the "Show in Slideshow" option but the slideshow isn't appearing. What am i doing wrong? Can someone help me please?

    Thanks.

  7. dietsmoke
    Member
    Posted 2 years ago #

    Hi,

    did anyone get the slideshow issue to work? I have an installation of the sight theme and it all worked well - but suddenly only one post is displayed in the slider and it doesn´t show the others anymore?

    thanks for your ideas...

  8. Mark
    Member
    Posted 2 years ago #

    I've just spent all night trying to get the slider to work in the Sight template and have just sorted it.

    josiahemsley is right in that you have to change "jquery.cookie.js" to "jquery.cooki.js" and you have to do this in TWO places.

    (1) in the theme directory (wp-content/themes/sight/js) change the filename of "jquery.cookie.js" to "jquery.cooki.js"

    (2) in the theme's header.php approximately (I changed some of the code above so it will be around this line) line 15 change
    wp_enqueue_script('cookie', get_template_directory_uri() . '/js/jquery.cookie.js', 'jquery', false);
    to
    wp_enqueue_script('cookie', get_template_directory_uri() . '/js/jquery.cooki.js', 'jquery', false);

    If you do both of these, it should work. I'm using WP 3.2.1.

  9. deidrecrawford
    Member
    Posted 2 years ago #

    Hello,
    I'm having the same issue as Mark of not having my slideshow show up, but I can't find where the "jquery.cookie.js" file is kept to change the name to "jquery.cooki.js".

    I have looked all over my WP and I can see all the different templates, like Header.php, Index.php, etc. but nothing that says jquery. I also can't find a theme directory.

    I use GoDaddy as my hosting and have my WordPress installed through them - could this cause things to appear (or be located) differently?

    If so, how do I find my jquery cookie file?

    I can find the jquery cookie file in the zip folder on my computer and as a last resort, I am wondering if I could change the name there and then re-upload the whole WordPress theme with the changed file name, but I'm wondering if that will create more complications?

    I would rather just change the name of the jquery cookie file online since it sounds so simple - I just need to find it.

  10. Prithvi
    Member
    Posted 2 years ago #

    Hi,
    I am pretty new to wordpress.
    I just installed the theme, everything works great but the slideshow is not working at all, not even a single post is shown. I tried all the options discussed above.
    Can anyone help on this!!

    Thanks inadvance.

  11. afrospaceman
    Member
    Posted 2 years ago #

    Thanks to Neosnc who came up with this fix

    Open the header.php

    Change 2 calls of is_home() to is_front_page()

    They are near lines 19 and line 52.

    Simples

  12. morganvicki
    Member
    Posted 2 years ago #

    I'm running WP 3.3.1 on http://www.morganvicki.com and just made the changes that Mark suggested above and everything is working fine now.

    Anyone know how to control the speed of the slideshow now?

    :)

  13. azharc
    Member
    Posted 2 years ago #

    Thanks for the solution Mark!

  14. Prithvi
    Member
    Posted 2 years ago #

    afrospaceman:

    You can find the options to change slideshow speed in "Theme Options" page in admin page. The numbers are given milliseconds.

    :)

  15. leosampieri
    Member
    Posted 2 years ago #

    Hi, everybody.
    I had this slider issue up to just a few minutes ago, when I replaced the slider section of style.css, with the text of a backup installation that did work. Finally I don't know how I fixed it!.
    Now it happens that when the slider shows on screen it consumes all the resources in my PC, and the graph of the CPU performance looks like a saw. Weird. When I'm not showing the slider on screen everything is fine.
    Ideas welcome.
    Cheers!
    LS.

  16. existentia
    Member
    Posted 2 years ago #

    tnx afrospaceman for that idea with afrospaceman is_home() -> is_front_page() change! now it slideshow works perfectly.

    but one new problem appeared: all the posts that became part of slideshow are not shown on home page among other posts, how to fix that? anyone knows?

  17. sophia3112
    Member
    Posted 2 years ago #

    Hallo,
    I just installed the Sight theme with in WP 3.3.2.
    The slider does not appear.
    Also I cannot see the HOME button - in other themes the Home button appears correctly.

    Can somebody help in this case.
    Thanks.

    Sophia

  18. leosampieri
    Member
    Posted 2 years ago #

    Try uninstalling and reinstalling the theme.
    I believe the 'home' button has to be hand made in appeareances > menus > personal links.
    Cheers!

  19. sophia3112
    Member
    Posted 2 years ago #

    Thank you, the HOME button works with the posts now.

    Still the slider does not work with WordPress 3.3.2. - I did all the steps listed above.

    I installed the theme over and over.

    Has anyone tested the SIGHT Theme with WordPress 3.3.2.

    Greetings
    Sophia

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.