WordPress.org

Ready to get started?Download WordPress

Forums

Genesis Simple Sidebars
Sidebars Not showing when selected (8 posts)

  1. cad60k
    Member
    Posted 5 months ago #

    Hi there

    Been using your plugin for years and I really appreciate the value you've added to the genesis framework.

    This is the first time I've had this issue with this plugin and it seemed to work before I updated genesis and wordpress.

    The issue is when I select the sidebar from the drop down in my edit page admin area it does not show that sidebar on the front end page after saving and refreshing.

    Not much else to it, just seems to not be working. I have done a full stop plugins and work from the ground up to see whats causing it, but it still seems to happen

    Regards
    Craig

    http://wordpress.org/plugins/genesis-simple-sidebars/

  2. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 5 months ago #

    What child theme are you using?

  3. cad60k
    Member
    Posted 5 months ago #

    Genesis Sample child theme, with a custom build.

  4. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 5 months ago #

    Have you made any widget area customizations?

  5. cad60k
    Member
    Posted 5 months ago #

    I have added some widget areas, but I normally do that. I cant seem to find anything that could be hindering the plugin

    Heres a link to my functions.php file if you want to check

    https://gist.github.com/thewebattic/8828101

    Thanks Craig

  6. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 5 months ago #

    Does it not show a sidebar at all? Or do you get the default sidebar instead?

  7. cad60k
    Member
    Posted 5 months ago #

    I'm just getting the default sidebar showing instead

  8. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 5 months ago #

    You should never use query_posts in your theme:

    function dma_change_post_order(){
            if ( is_archive() ){
                global $wp_query;
                $args = array_merge( $wp_query->query, array( 'orderby' => 'title','order' => 'ASC' ) );
                query_posts( $args );
        }
    }
    add_action('genesis_before_loop','dma_change_post_order');

    use pre_get_posts instead.

    Try commenting that out & adding the following to your child theme

    add_action( 'genesis_after_loop', 'wp_reset_query' );

Reply

You must log in to post.

About this Plugin

About this Topic