WordPress.org

Ready to get started?Download WordPress

Forums

Sidebar Login
sidebarlogin() function not working after update (14 posts)

  1. Morgan Kay
    Member
    Posted 1 year ago #

    I updated to 2.5 today, and now the sidebarlogin() function no longer works. There is now nothing in my theme where I call the sidebarlogin() function. Did you remove or change this function? I've reverted to an older version of the plugin for now.

    http://wordpress.org/extend/plugins/sidebar-login/

  2. DirtModeler
    Member
    Posted 1 year ago #

    Same issue happened with me too... It has broken since the update.

    I'm running the Admired Theme.

    I don't have the old files for the previous version... and kinda stuck until they fix the update.

  3. Grimpond
    Member
    Posted 1 year ago #

    I had a few issues post upgrade... Go to your Sidebar Login widget and check the settings and re-save it.

    Fixed things for me

    G

  4. DirtModeler
    Member
    Posted 1 year ago #

    Thanks Grimpond.

    That's confirmed. Going to the Widget and just clicking save fixes the error.

  5. Morgan Kay
    Member
    Posted 1 year ago #

    I'm not using the widget - I'm using the template function, so I can't save widget settings.

  6. ketzelle
    Member
    Posted 1 year ago #

    same issue as Morgan.

  7. onetrev
    Member
    Posted 1 year ago #

    Looks like maybe the plugin author removed the template tag -> sidebarlogin() function.

    To use this plugin in a template I think you need to do this now (as per instructions on plugin home page)

    "To use this widget in a template, use the the_widget() function which WordPress provides."

  8. NixWit
    Member
    Posted 1 year ago #

    "To use this widget in a template, use the the_widget() function which WordPress provides."

    This is only written on the plugin-page at wordpress.
    But anyway, it is also not working with this plugin.

    On the authors page, it is written:

    "To use the template tag: Add <?php sidebarlogin(); ?> to your template."

    The same in the readme.txt (but the readme is still 2.4 :-( )

    But also not working on my sites. I think, we have to go back to 2.4, which was working in templates.

  9. kremerdesign
    Member
    Posted 1 year ago #

    I tried the combos below, and other similar but couldn't get it working either. Don't know if I hvae the wrong plugin name?

    any ideas?

    <?php the_widget('sidebarlogin'); ?>
    <?php the_widget('sidebar-login'); ?>
  10. tb2011
    Member
    Posted 1 year ago #

    Same issue here. We used Allow PHP in post with the code [php] sidebarlogin(); [/php]. It was working fine until the upgrade. Now the login has disappeared. I tried a number of things mentioned above but none is working.

    How can I revert to the older version of the plugin until someone figures this out? Is the old plugin version still available for download somewhere?

    Let me know - thanks!

  11. tkan
    Member
    Posted 1 year ago #

    For those who used the template tag:

    just widgetize your template with

    <?php
    if ( dynamic_sidebar('secondary-widget-area') ) :
    else :
    ?>

    You may have to register a sidebar within the functions.php but that's quite easy. If successfully done, you may activate the widget.

    I think that's a concenvenient way to use the plugin furthermore.

  12. raphaelsegerman
    Member
    Posted 1 year ago #

    Simply replace

    <?php sidebarlogin(); ?>

    with

    <?php the_widget('Sidebar_Login_Widget'); ?>

  13. wordcolors
    Member
    Posted 1 year ago #

    I'm using the widget, and all the settings are correct -- but going to the widget and clicking Save didn't fix the error for me as it did for Grimpond and Dirtmodeler. So, it looks like I'm stuck with the error until an update.

    TB2011, has anyone provided you with a way to download the previous version of the plugin? If so, will you please let me know?

  14. eatdrinkdeals
    Member
    Posted 6 months ago #

    Just saving the widget did not work for me, but this did work:
    1. Uncheck "Show Password Link"
    2. Uncheck "Show Register Link"
    3. Save
    4. Re-check those two boxes
    5. Save.
    Hope this works for others as well.

    [ Signature moderated. ]

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.