WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Sidebar won't display (10 posts)

  1. vagabond_uk
    Member
    Posted 4 years ago #

    Hi,

    I'm trying to port my work's existing website onto WordPress and I've encountered an infuriating problem that I cannot work out how to solve. I am using WordPress 3.0 with the 2010Weaver (Ivory Drive) theme.

    I have setup a static homepage in WordPress and in order to display my blog posts, I have created a second page called 'news' which is where I want my blog posts to go to. I've set this up in the 'Reading' section of the admin panel.

    I'm using a plugin called 'Sidebar Generator' to create custom sidebars depending on the page being viewed. When the 'news' page is displayed, I want to display a custom 'news' sidebar to be displayed and have defined the call in the page creation to call the 'news' sidebar when the news page is viewed.

    However, the sidebar doesn't display in the news listings page (www.mysite.com/news), although it DOES display when the individual post is clicked through (www.mysite/news/news-item).

    I can't seem to figure out why the sidebar isn't being displayed on the top-level news page, but is being displayed on individual items..

    You'll see what I mean at http://is.gd/dJVpE

    Help!

  2. vagabond_uk
    Member
    Posted 4 years ago #

    ...

    Anyone?

  3. Are you using a page template - a modified page.php - for the news page and does it include the sidebar call? Liek single.php does?
    Page Templates « WordPress Codex

  4. vagabond_uk
    Member
    Posted 4 years ago #

    Hi,

    Yes, I'm using a modified page.php and it does include a sidebar call... here's the full code...

    <?php /* Template Name: EBSNews */ ?>

    <?php get_header(); ?>

    <div id="container">
    <?php if (!get_option('ttw_hide_widg_pages') && is_active_sidebar('top-widget-area')) { /* add top and bottom widget areas */ ?>
    <div id="ttw-top-widget" class="widget-area" role="complementary" ><ul class="xoxo">
    <?php dynamic_sidebar('top-widget-area'); ?>
    </div>
    <?php } ?>

    <div id="content">

    <?php the_post(); ?>

    <div id="post-<?php the_ID(); ?>" <?php post_class(); ?>>
    <?php if ( is_front_page() ) { ?>
    <h2 class="entry-title"><!- -?php the_title(); ?- -></h2>
    <?php } else { ?>
    <h1 class="entry-title"><!- -?php the_title(); ?- -></h1>
    <?php } ?>

    <div class="entry-content">
    <?php the_content(); ?>
    <?php wp_link_pages( array( 'before' => '<div class="page-link">' . __( 'Pages:', 'twentyten' ), 'after' => '</div>' ) ); ?>
    <?php edit_post_link( __( 'Edit', 'twentyten' ), '<span class="edit-link">', '</span>' ); ?>
    </div><!-- .entry-content -->
    </div><!-- #post-<?php the_ID(); ?> -->

    </div><!-- #content -->
    <?php if (!get_option('ttw_hide_widg_pages') && is_active_sidebar('bottom-widget-area')) { /* add top and bottom widget areas */ ?>
    <div id="ttw-bot-widget" class="widget-area" role="complementary" ><ul class="xoxo">
    <?php dynamic_sidebar('bottom-widget-area'); ?>
    </div>
    <?php } ?>
    </div><!-- #container -->

    <?php get_sidebar(); ?>
    <?php get_footer(); ?>

  5. vagabond_uk
    Member
    Posted 4 years ago #

    Ok, i've switched the page template back to 'Default' and i'm getting the same result - custom sidebar won't display on the top-level page but will on single posts...

    Also noticed that the 'archives' page suffers from the same problem.

    I've found a plugin that lets me add posts inline inside the page, but while a workaround, its not what I'm after.

    I'm going slowly bald ripping my hair out over this.

  6. vagabond_uk
    Member
    Posted 4 years ago #

    ...

  7. vagabond_uk
    Member
    Posted 4 years ago #

    Installed WP2.8.4 and tried the plugin on the default Kubrick theme... same result.

    Updating the plugin causes it to break completely under WP3.0.

    I don't know what else to try.. the plugin just doesn't want to work with static pages.

  8. vagabond_uk
    Member
    Posted 4 years ago #

    Tried it, but it doesn't quite meet my needs.

    I think I've tracked down the problem though. In the plugin code there is a call to check if the page is a single page and if not, then don't display the sidebar. Playing with it now to see if i can get it to work.

  9. thestealthyfox
    Member
    Posted 3 years ago #

    Hi

    I'm having the exact same problem, did you manage to solve this or has anyone else come across this?

    Have disabled plugins as I thought these might be conflicting, but to no avail. I don't understand the coding too well so not sure what to look for there.

    Help anyone!

Topic Closed

This topic has been closed to new replies.

About this Topic