WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Sidebar Widgets Won't Update (6 posts)

  1. madcasey
    Member
    Posted 6 years ago #

    Hi all,

    I have a brand new install of WordPress 2.3.1 running the WordPress Classic theme at my site: http://www.MarkCaseyOnline.com

    I'm trying to configure the widgets for the sidebar, but every time I change (drag and drop) what's supposed to be displayed, nothing changes on my actual site. It just keeps the default display up.

    The only thing I've changed about the theme PHP files is to float the sidebar left, along with some of the margin values that go along with it.

    Any suggestions? I know the version of classic I have, which came with the new install, is the current widgetized version 1.5.

    Thanks so much!

  2. Adam Brown
    Member
    Posted 6 years ago #

    Are you using only the default widgets, or have you downloaded additional widgets as plugins?

  3. madcasey
    Member
    Posted 6 years ago #

    I'm only using the sidebar widget that came with the download, nothing else.

    BUT I should mention that besides floating the sidebar to the left, I also changed the code to call the sidebar before the content. It's being called from my Header.PHP file, before the <body>. I don't think this would cause the widget to cease functionality, would it?

  4. Adam Brown
    Member
    Posted 6 years ago #

    BUT I should mention that besides floating the sidebar to the left, I also changed the code to call the sidebar before the content. It's being called from my Header.PHP file, before the <body>. I don't think this would cause the widget to cease functionality, would it?

    That's unrelated, but not a good thing. You shouldn't have that before the <body> tag or you're going to have unpredictable weirdness when people view your blog depending on what browser they're using.

    Since it doesn't sound like it's being caused by a particular widget, try searching. There have been lots of posts about this sort of thing:

    http://wordpress.org/search/widgets+update?forums=1&p=2

    Here's a longish thread with several suggestions worth trying:

    http://wordpress.org/support/topic/105327?replies=29

  5. madcasey
    Member
    Posted 6 years ago #

    Another odd thing... I have three themes: Default Kubrick, WordPress Classic, and Silver Light.

    The sidebar widgets work with the default theme, but not Classic (on which it worked yesterday), and not Silver Light, which I hadn't tried until just now.

    A little odd. Is there a simple way to reinstall the widget, or would that not even make a difference?

  6. madcasey
    Member
    Posted 6 years ago #

    Solved!

    Thanks a lot for your help--turns out that the Classic sidebar I was using was *not* widgetized.

Topic Closed

This topic has been closed to new replies.

About this Topic