WordPress.org

Ready to get started?Download WordPress

Forums

Sidebar widgets are not clickable (12 posts)

  1. LankaLion
    Member
    Posted 3 years ago #

    I have an issue which is common for IE and Firefox. I am using widgets (mainly text) in the right sidebar. They were working fine earlier. However, now when I click the widgets (down arrow key to expand the widget) nothing happens.

    This is also an issue of the menu items on the left menu bar. Nothing happens when I click the down arrow key to expand sub items of a menu item (example: media).

    Due to this problem I cannot edit widgets, especially "Text" widgets.

    Can someone please help. I am using Windows 7 OS.

  2. kmessinger
    Volunteer Moderator
    Posted 3 years ago #

    Have you tried:

    - deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). Don't forget the ones in mu-plugins. If you can't get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

  3. LankaLion
    Member
    Posted 3 years ago #

    Hi kmssinger,

    I deleted all deactivated plugins. Then deactivated all active plugins. This did not resolve the problem. Then I changed the theme to twenty eleven. But no luck yet.

    I have multiple self hosted WordPress blogs using different themes. They all are having the same issue. Not sure whether this is something to do with Windows.

  4. kmessinger
    Volunteer Moderator
    Posted 3 years ago #

    This has nothing to do with the OS. Any problem on the backend is likely caused by a javascript conflict or a missing/corrupted file.

    Delete the wp-admin and wp-includes folders on your server. DO NOT delete the wp-content folder. Download a fresh copy of WP. Unzip and upload to the server the wp-admin and wp-includes folders.

  5. LankaLion
    Member
    Posted 3 years ago #

    Thanks for your response kmessinger. I did exactly what you said, but no luck yet.

    There are few interesting points to notice.

    1. I have over 10 blogs, hosted through different web hosters. All of them are having the same issue.

    2. Blogs are using different themes and plugins.

    3. All of these blogs were working fine earlier.

    I have noticed the same issue in different discussion forums including WordPress. None of them have a solution.

  6. senortim
    Member
    Posted 2 years ago #

    I'm having the same -- or at least a very similar -- problem. The site (not public) is http://ipen.org/hgf2/ and is running WP3.2.1.

    I've tried the things suggested above, with no success. One difference from @LankaLion is that I have at least two other sites on this same server and domain that are using the same theme (TwentyTen) and are working just fine.

    I thought perhaps it was a CSS thing, with a layer above my current sidebar, but I cannot locate any offending CSS. My own customizations to the CSS don't modify the width of the #content DIV, which when I double click seems to be affected.

    Thanks,
    Tim

  7. Xam 1.0
    Member
    Posted 2 years ago #

    @ LankaLion

    I have over 10 blogs, hosted through different web hosters. All of them are having the same issue.

    If the problem is on all your blogs on multiple webhosts it's not server or wordpress related, it's probably you. Did you disable javascript in your browser?

  8. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    @senortim When at the widgets screen is the word "add" next to the widget name? If so go to screen options (upper right) and uncheck accessibility mode.

  9. LankaLion
    Member
    Posted 2 years ago #

    I upgraded Firefox to the latest version and this problem is no more with Firefox. IE is still having the issue.

    Xam 1.0

    I haven't disabled Javascript.

  10. senortim
    Member
    Posted 2 years ago #

    @kmessinger In Screen Options, accessibility appears to be disabled. I toggled it ona dn off, with no effect. Other ideas? (PS: Sorry for misspellings, if any; since I upgraded to FF6, my fonts are totally hosed, and I'm typing half blind.)

  11. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    accessibility appears to be disabled

    Another sign of javascript conflict. I am pretty sure that is not a theme specific option.

    Have you tried:
    - deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). Don't forget the ones in mu-plugins if you have that folder. If you can't get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.
    - switching to the Twenty Eleven theme to rule out any theme-specific problems. Since you have 2 sites that use this theme and they are ok, I would think it a theme issue except for what I said in the first paragraph.

    Do you have Firebug? If so you can turn it on. Have it in the debug script mode and sign into the dashboard. You should be able to tell where things get hung up.

  12. senortim
    Member
    Posted 2 years ago #

    I found it. My problem _was indeed_ with CSS. I gave #container the position:relative setting and -- though I'm still not sure why -- this somehow prevented sidebars from receiving clicks.

    I did this because I wanted to position a sidebar that was specific to my page content (rather than via a Text Widget). To fix it, I just wrapped my sidebar in another DIV and set it's position to relative. (It took **much longer** to find than fix; isn't that always the way?)

Topic Closed

This topic has been closed to new replies.

About this Topic