WordPress.org

Ready to get started?Download WordPress

Forums

Sidebar widgets are at bottom of post (11 posts)

  1. KrystleS
    Member
    Posted 2 years ago #

    I know this question has been asked before but I feel like I need in-depth help because I am so confused. A few days ago half of the widgets in my sidebar started showing up at the bottom of the post. I don't know how to fix it. I have tried removing some of the widgets and deactivating then reactivating. So far no improvements. I have also seen that some coding might be a problem but I don't know how to read it much less tell what's wrong with it. I would appreciate any help I could get.

    http://www.colortransformedfamily.com

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    Start by sorting out any markup errors. Then move onto CSS errors.
    http://codex.wordpress.org/Validating_a_Website

  3. KrystleS
    Member
    Posted 2 years ago #

    I am aware that I have errors but don't know how/where to actually correct these.

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    Please see the page I linked to above.

  5. KrystleS
    Member
    Posted 2 years ago #

    I went to the page and did a scan that came up with 38 errors and 4 warnings. I am not sure where I go to fix these though. I am not familiar with coding at all.

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    If you cannot sort the issues out yourself, you may have to consider hiring someone. Try http://codepoet.com/ or http://jobs.wordpress.net/

  7. KrystleS
    Member
    Posted 2 years ago #

    I would love to sort this out myself but feel your help is very vague. Do I fix the errors on the through the link you sent me or on my actual website. If on the website where? I only know where to find the HTML information for each post not for the actual page.

  8. alchymyth
    The Sweeper & Moderator
    Posted 2 years ago #

    can you post a direct link to a post where the sidebar is at the bottom?

    which browser are you using?

    have you tried to clear the browser cache?

    at the moment, I see the sidebar on the right side, apart from one single square footer widget.

  9. esmi
    Forum Moderator
    Posted 2 years ago #

    Do I fix the errors on the through the link you sent me or on my actual website.

    On your website.

    where?

    You have to work backwards to find the template file or content block that is causing the issue. You can find an overview of the template files that your theme may, or may not, contain in Theme Development.

  10. KrystleS
    Member
    Posted 2 years ago #

    I am using Safari.. and now I don't see any of the sidebar on the single posts. This just happened a few seconds ago. It has happened before but I can't remember what I did to fix it. I do know that the sidebar was working fine on FireFox earlier today... safari was giving me the problems.
    http://www.colortransformedfamily.com/2012/03/06/drapery-transformation/

  11. alchymyth
    The Sweeper & Moderator
    Posted 2 years ago #

    that is normal - i.e. by design - that single posts don't have a sidebar in Twenty Eleven.

    there are plenty forum topics about how to change that.

Topic Closed

This topic has been closed to new replies.

About this Topic