WordPress.org

Ready to get started?Download WordPress

Forums

Twenty Twelve
[resolved] Sidebar widget items not allowing me to edit them (8 posts)

  1. flemingworks
    Member
    Posted 1 year ago #

    I just installed the Twenty Twelve today and have been making changes on my child theme. I would like to change the widgets in my main sidebar but when I click on them they do not pop-out so that I can edit/delete them. I have tried viewing the widget panel from the dashboard on firefox and safari but in both versions they are not working properly like they have in past websites I have created.

    Any idea what could be causing this?

    Here is an visual example of what happens when I click on the "recent posts" widget in the sidebar : http://i1024.photobucket.com/albums/y308/flemingworks/ScreenShot2013-01-03at70234PM_zps929424bf.png

    Thanks!

  2. Kurt
    Member
    Posted 1 year ago #

    flemingworks: Is javascript disabled in your browser? That's what it looks like to me.

  3. leejosepho
    Member
    Posted 1 year ago #

    Any idea what could be causing this?

    Yes, an idea. In my own case a few days ago, I had some kind of block going in .htaccess, and the Dashboard problem immediately disappeared after I had fixed that.

  4. gidd
    Member
    Posted 1 year ago #

    Most of the time, it is a JavaScript problem, I used to face it for one of my client projects. It is caused by JavaScript not working properly or conflicts.

  5. gidd
    Member
    Posted 1 year ago #

    Maybe you can activate the parent theme and see if it works properly.
    If it works, there is something wrong with your child theme.

  6. flemingworks
    Member
    Posted 1 year ago #

    Hi,
    Thanks for all the replies everyone. I activated the Twenty Twelve as well as the Twenty Eleven parent themes and in both cases I faced the same problem.

    I made sure that firefox has javascript enabled and ticked all the boxes in the advanced panel as well.

    Am still having the problem.

    @leejosepho what change did you make to the htaccess file to fix it?

    Thanks!

  7. leejosepho
    Member
    Posted 1 year ago #

    Am still having the problem.

    @leejosepho what change did you make to the htaccess file to fix it?

    I went to my server via FTP and deleted .htaccess, then put this default back in place:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    I do not understand very much about all of that, but that worked for me and you can find some good reading about that kind of stuff over here:
    http://wordpress.org/support/plugin/bulletproof-security

  8. flemingworks
    Member
    Posted 1 year ago #

    Hi, @leejosepho

    thanks for sending that through. Before changing the htaccess file I scanned the posts in the link and saw some comments that made me think it might be related to other plugins I am running. So I deactived two plugins I had been running - Slick Contact Forms and WP Coming Soon - and it fixed the problem for me. One of those plugins must have been causing the error.

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic