WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Sidebar still not displaying nested links (4 posts)

  1. absolutecm
    Member
    Posted 4 years ago #

    I've created my first theme and posted this problem last week but still not having any joy!

    The link is http://www.gloucestercivictrust.org/news/

    The widgetized sidebar isn't displaying nested links. I've styled the titles okay but can't get the links below to display.

    If you view source on the page you can see the code is visible, so I don't understand why they aren't displaying in the browser.

    Would really appreciate some help with this as the site is going live next week! Please let me know if you need any code etc.

    TIA

  2. jamiedustuk
    Member
    Posted 4 years ago #

    had a quick loko at your style sheet there is a display none on a list element, its probably inheriting that, i can see the code:

    li ul {
      display: none;
      position: absolute;
      top: 1em;
      left: 0;
      z-index:1;
    
    }

    you will have to respecify the values for the li and ul in the sidebar, get rid of the absolute position and display none, something like:

    #sidebar li,#sidebar ul{
      display:block;
      position:static;
    }
  3. kapiljain.in
    Member
    Posted 4 years ago #

    Hi,

    Link is working properly in Firefox but not in IE

    Try after doing following changes (backup current file before making any change):

    1. Remove width: 300px; in style.css

    #sidebar-list ul, #sidebar-list ul ol {
    	margin: 0;
    	padding: 0;
    	width: 300px;
    }

    2. Since margin not works properly in IE, change float: left to float: right and remove margin-left: 20px; in following class

    #right {
    	width: 270px;
    	margin-left: 20px;
    	float: left;
    	border-left: solid 1px #999;
    	padding: 0px 15px;
    }

    and put <div style="clear: both;"></div> just after closing <div id="right">

    Note: please take backups before making changes.

    Let me know if it not works, I will check further

    Thanks
    Kapil Jain

  4. absolutecm
    Member
    Posted 4 years ago #

    Many thanks jamiedustuk!

    That got it visible, trying to style it now. Having trouble removing the >> on each list item, gone through the css and can't see how this is being generated.

    Off to try Kapil's suggestion now!

    Many, many thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags