WordPress.org

Ready to get started?Download WordPress

Forums

sidebar not getting called? (9 posts)

  1. twlack
    Member
    Posted 4 years ago #

    I was working on this site a lot with WP e-commerce plugin trying to do some things that maybe where over my head. But I started to see that some of my theme pages were not being called from my selected theme folder. So I cleaned up the server, deleting all the themes that I wasn't supposed to be using.

    Well now my theme won't call the sidebar.

    So I went to the 3 theme folders and added this line to the top (very first line) of each index.php page:

    <!-- /wp-content/themes/baitpens/index.php -->
    <!-- /wp-content/themes/default/index.php -->
    <!-- /wp-content/themes/classic/index.php -->

    And none of those comments show on the served page. Shouldn't it? Isn't that the starting page which calls everything else? Is there another place to look for index.php?

    http://baitbaskets.com/

    Thanks for any help,
    Tim

  2. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    <?php get_header(); ?>

    is that the first line of your index.php?

    put your comments after that line

  3. twlack
    Member
    Posted 4 years ago #

    Was:
    <!-- /baitbaskets.com/wp-content/themes/baitpens/index.php -->
    <?php get_header(); ?>

    Changed to:
    <?php get_header(); ?>
    <!-- /baitbaskets.com/wp-content/themes/baitpens/index.php -->

    Same results, the comment does not show when I look at the HTML in FireFox.

    But I did just try switching to the "default" theme and my sidebar was called.

    These are the last 2 lines of index.php of the "baitpens" theme:

    <?php get_sidebar(); ?>
    <?php get_footer(); ?>

    The footer is called the sidebar is not.

  4. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    the baitpens theme has a sidebar.php?

  5. twlack
    Member
    Posted 4 years ago #

    Yes

  6. twlack
    Member
    Posted 4 years ago #

    I have an almost identical theme working at:

    http://lackwood.com/

    And I've compared the 2 closely and can't find anything that might be causing this. I even search the 2 data bases to see if there is some setting that seemed different. Can't find anything unusual.

  7. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    I assume you have widgets in the sidebar that should be showing?

  8. twlack
    Member
    Posted 4 years ago #

    Yes, the code is:

    <?php /* WordPress Widget Support */ if (function_exists('dynamic_sidebar') and dynamic_sidebar(1)) { } else { ?>

    and then it calls pages, bookmarks, etc and formats them. In that respect it is identical to the sidebar at lackwood.com

  9. twlack
    Member
    Posted 4 years ago #

    I went back to a copy of the theme folder I saved a couple days ago and it is showing the sidebar. I will have to see if I can find what I did to cause this problem.

    Fortunately most of the work I was doing was to the e-commerce plug in which has its own theme folder so almost all the work I did still works with the old (current) theme.

    If I figure this out I will post it here if it isn't a stupid mistake.

    Thanks,
    Tim

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.