WordPress.org

Ready to get started?Download WordPress

Forums

Sidebar not displaying Pages (8 posts)

  1. xc1729
    Member
    Posted 1 year ago #

    I'm currently using Expositio provided by wpshower.

    I'm not really entirely sure where I've gone wrong but the sidebar isn't showing any pages even though In the menu settings I have selected a certain menu to be displayed. I am thinking I have gone wrong somewhere in the code and I'm not really sure where.

    Any help would be GREATLY appreciated to get this solved!

  2. James Kirk
    Member
    Posted 1 year ago #

    Heya xc1729,

    Any chance of seeing the sidebar-challenged website live? If you could post a link that would be great!

    You mentioned something might have gone wrong in the code. Did you add or make any changes to the style.css? Specifically, is:

    #wps-sidebar {display: none;}

    in there anywhere?

    Cheers! :)

    P.S. I see there's not much activity in their forum where you posted this challenge over there. Hate when that happens! :)

  3. xc1729
    Member
    Posted 1 year ago #

    My website is alexclaydon.co.uk

    I reinstalled the style.css file to the database just incase I had changed anything before and that doesn't seem of done anything, and I don't see that anywhere in my style.css file either.

  4. James Kirk
    Member
    Posted 1 year ago #

    Heya Alex,

    Yeah, have you tried deactivating all your plugins like jet pack and others to see if there is a negative interaction causing the theme not to show up the sidebar content.

    I'm sure you do, but are there widgets placed in the sidebar in the WP backend?

    Cheers! :)

  5. xc1729
    Member
    Posted 1 year ago #

    Hey,

    Just deactivated jetpack and all my plugins but to no conclusion and does not seem to of done anything.

    I have 1 or 2 widgets placed in the sidebar and I had previously widgetized the theme as it wasn't widget ready before, but I also "un-widgetized" it to as I didn't want the drop down menu option.

    So during the process of reversing the widgetizing could of possibly done something but nothing I can see in the code atm.

    Many thanks.

  6. James Kirk
    Member
    Posted 1 year ago #

    Heya Alex,

    Ahhhh, the truth emerges! Okay, so at this point I would ask you if you have (or can get) the original theme files? That is how I would proceed. Find the code that hasn't been altered and works and then start from that point.

    Also, are you using child themes for all this hacking around? Will make your upgrades less painful if you do!

    Cheers! :)

  7. xc1729
    Member
    Posted 1 year ago #

    I will probably just reinstall the whole thing again and start from scratch and hope that the menus will appear again. I feel like its the only option instead of messing up the code.

    Many thanks for your help with this issue.

  8. James Kirk
    Member
    Posted 1 year ago #

    Roger that. Definitely consider creating a child theme this next go around. Makes the changes you make very easy to back out from.

    http://codex.wordpress.org/Child_Themes

    Cheers! :)

Topic Closed

This topic has been closed to new replies.

About this Topic