WordPress.org

Ready to get started?Download WordPress

Forums

Sidebar - no links and categories initially (4 posts)

  1. RoscoHead
    Member
    Posted 9 years ago #

    Hi, thanks for a great BLOG!

    I have a little problem, I recently installed WP 1.5 here http://www.br-eng.info/words/ - and changed the theme to look like the rest of my site, with the sidebar on the left.

    The problem is, when I visit the main page after a long wait, it displays "No categories" under Categories, and no links. But when I refresh the page, they display fine. It uses wp_list_pages() and list_cats() exactly as per the default sidebar, they haven't been modified. I thought it might be a problem with initialising $post, so I added the dummy line from index.php:

    <?php $post = $posts[0]; // Hack. Set $post so that the_date() works. ?>

    But still the problem persists. Anyone have any ideas what might be happening?

    Thanks

    ROSCO

  2. Lorelle
    Member
    Posted 9 years ago #

    Do you have any posts within the categories? You have to have posts in the categories in order for them to show unless you have the tag set to show them.

  3. RoscoHead
    Member
    Posted 9 years ago #

    Thanks for the suggestion, but obviously there are or I would not have said "But when I refresh the page, they display fine."

    This problem is still present, go ahead click the link you'll see "No categories", hit refresh and they magically appear. Is nobody else having this problem?

  4. RoscoHead
    Member
    Posted 7 years ago #

    Just in case anyone else was having this problem, it turned out to be a bug in the weather_report plugin. An upgrade fixed it.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.