WordPress.org

Ready to get started?Download WordPress

Forums

Sidebar missing (6 posts)

  1. dizzyland
    Member
    Posted 1 year ago #

    The sidebar is missing on the blog page (tcbycu.com/blog) and I cant figure out what is causing it.

    I am using the same page template as I did on the "about" and "home" pages but the sidebar is nowhere to be found.

    I've searched everywhere and I can't seem to find the cause. Any advice would be most appreciated.

  2. viky081
    Member
    Posted 1 year ago #

    can you place the template code here ! ?

  3. dizzyland
    Member
    Posted 1 year ago #

    <?php
    /*
    Template Name: About Page
    */
    ?>
    
    <?php get_header(); ?>
    
    <div id="content">
    	<div id="content-inside">
    
    			<?php if (have_posts()) : while (have_posts()) : the_post(); ?>
    
    			<div id="post-<?php the_ID(); ?>" class="post-item single-post-item">
    
    				<div class="post-content">
    					<?php the_content(''); ?>
    				</div> <!-- post-content -->
    			</div> <!-- post-item -->
    
    			<?php endwhile; else : ?>
    
    			<div id="nothing-here" class="post-item single-post-item">
    				<h2>Whoops!!! Nothing Here by That Name</h2>
    
    				<div class="post-content">
    					<p>Very sorry, but what you are looking for isn't here. Maybe you should try one of the links below.</p>
    
    					<h4 class="not-here">Find Posts by Title:</h4>
    					<ul>
    						<?php query_posts('&showposts=1000&orderby=title&order=asc'); if (have_posts()) : while (have_posts()) : the_post(); ?>
    						<li><a href="<?php the_permalink() ?>" rel="bookmark" title="<?php the_title_attribute(); ?>"><?php the_title(); ?></a></li>
    						<?php endwhile; endif; ?>
    					</ul>
    
    					<h4 class="not-here">Find Posts by Month:</h4>
    					<ul>
    						<?php wp_get_archives('type=monthly'); ?>
    					</ul>
    
    					<h4 class="not-here">Find Posts by Category:</h4>
    					<ul>
    						<?php wp_list_categories('title_li='); ?>
    					</ul>
    
    					<h4 class="not-here">Maybe a Page:</h4>
    					<ul>
    						<?php wp_list_pages('title_li='); ?>
    					</ul>
    				</div> <!-- post-content -->
    			</div> <!-- post-item -->
    
    			<?php endif; ?>
    
    		</div> <!-- posts-page -->
    
    		<?php get_sidebar(); ?>
    	</div> <!-- content-inside -->
    </div> <!-- content -->
    
    <?php get_footer(); ?>
  4. dizzyland
    Member
    Posted 1 year ago #

    Not sure if that's what you were looking for. It's really weird because the sidebar is working on all of the other pages using the same template. I'm lost.

    PS... thank you. :)

  5. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Looks fine to me on the blog page -- sidebar has store location and hours, right? Try clearing any caches. What browser are you using?

  6. dizzyland
    Member
    Posted 1 year ago #

    I'm a space cadet. I just figured it out.

    I have a sidebar for multiple post pages that is automatically used no mater which template I use. My bad completely. Sorry about that!

Topic Closed

This topic has been closed to new replies.

About this Topic