WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Sidebar is pushed down on custom post type single post page (custom theme) (5 posts)

  1. keysuuh
    Member
    Posted 1 year ago #

    A while ago I changed the content within a few of my Theme's files. I created new files such as loop.php, loop-single.php, single-events.php and quite a few format-{post-format}.php files.

    I recently created a Custom post type named Events and
    everything was working smoothly until I attempted to fix up the single post page to the Events post type. The sidebar now gets pushed down. I've done a tad bit of research and the results were to check the HTML Validation ect, there were no end tags missing or anything for this to be happening. I strongly believe it has something to do with my loop-single, loop, or single-events.php files.

    I just need help adding or removing whatever code necessary to get the sidebar back up in it's correct position on this specific custom post type.

    I've pasted the files I feel are most important inside of these pastebins//

    First off here is my new index.php//
    http://pastebin.com/Bsz2vfrv

    loop.php//
    <?php while ( have_posts() ) : the_post(); $format = get_post_format(); if (! $format ) $format = 'standard'; get_template_part('format', $format); endwhile; ?>

    loop-single.php//

    <?php get_template_part('format', $format); ?>

    single.php (if needed)//
    http://pastebin.com/gFRix2xg

    single-events.php// http://pastebin.com/BFQGZpAA

    Appreciate the help.

  2. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    The sidebar now gets pushed down

    always? not just on the single 'events' post?

    have you tried to clear the browser cache?

    check the HTML Validation ect, there were no end tags missing or anything for this to be happening

    in which case, it might be a css issue which cannot be checked without a live link to the problem site.

  3. keysuuh
    Member
    Posted 1 year ago #

    Alchymyth, No not always only on the Single events post.

    I checked my css and there are no major issues that could have caused this...

    If you check the single.php html you'll see that I have IF gallery format at the top and regular single post at the bottom...

    Might that file be the issue?

    Here is the URL//
    http://pastebin.com/F7zHnCM3

    (I want to be able to delete my url so I just pasted it in a pastebin)

  4. keysuuh
    Member
    Posted 1 year ago #

    Also, If I delete the 'single-events.php' file the sidebar goes back to it's regular position.

  5. keysuuh
    Member
    Posted 1 year ago #

    Fixed it :)

Topic Closed

This topic has been closed to new replies.

About this Topic