WordPress.org

Ready to get started?Download WordPress

Forums

side navigation broke (4 posts)

  1. donnytree
    Member
    Posted 3 years ago #

    I use wp_list_pages to generate the side navigation on my site,
    wp_list_pages("title_li=&child_of=$parent&depth=0");

    For some reason it now reloads the entire menu every time you click on a menu item. It used to just add the menu items, no reloading the entire menu. I tried some CSS to fix it, but it's problematic once you get 3 or more levels down. Anyone having a similar problem or know how to fix it?

  2. ron moss
    Member
    Posted 3 years ago #

    Same problem overhere, with:
    <?php wp_list_pages('title_li=&depth=0' ); ?>
    this makes an extra ul li altought there no child items, so for example for the home:

      <li class="page_item page-item-2 current_page_item">Home
      <ul class="page-item-2">

    I've seen this for the first time, with other websites (hosted at different hosting providers i not come across this problem..).
    So I suspect this has something to do with the host (php versions??)

    gr,
    Ron Mosss

  3. donnytree
    Member
    Posted 3 years ago #

    Hi Ron,
    This isn't the same problem that I am talking about. I think yours is happening because you are not setting "title_li=" to anything. Check here for information on how to define this element: http://codex.wordpress.org/Function_Reference/wp_list_pages

    Donna

  4. donnytree
    Member
    Posted 3 years ago #

    Scratch that Ron, sorry. I am having a different problem than you but I am not sure what's going on with yours...

Topic Closed

This topic has been closed to new replies.

About this Topic