WordPress.org

Ready to get started?Download WordPress

Forums

Google Calendar Events
[resolved] Shows only current month (12 posts)

  1. Sabapete
    Member
    Posted 6 months ago #

    The only month that comes up is February (current). How can I scroll or change the month to any that follows?

    https://wordpress.org/plugins/google-calendar-events/

  2. Ross Hanney
    Member
    Plugin Contributor

    Posted 6 months ago #

    Hello,

    If you're using the widget, set the "Display events as" option in the widget settings (Appearance > Widgets) to "Calendar grid - with AJAX".

    If you're using the [google-calendar-events] shortcode, set the type parameter to ajax, as below.

    [google-calendar events type="ajax"]

    If you're still having problems, let me know.

  3. Stjohn Rowlands
    Member
    Posted 6 months ago #

    Hi Ross

    I've the same problem I've tried [google-calendar-events type="ajax"]
    but this just leads to the shortcode being displayed!

    Looks a genius piece of work thogh - thank you.

    http://www.doggy-woof.com/events/calendar/

  4. Fonglespore
    Member
    Posted 6 months ago #

    I thought I had this problem too.

    First: check that there's an event in the next/prev month - otherwise the link won't appear. I'm not sure if that hold if the next event is more than a month away or not.

    Second: look closely over the first & last days of the week. That's where the link appears and it's very small (for my site anyway).

    I'm trying to find the symbols in the code & replace them with something more visible.

  5. Stjohn Rowlands
    Member
    Posted 6 months ago #

    There are events in there and I really can't see the buttons. I'm using an XML feed and the resposive them are there any known conflicts/.

  6. Stjohn Rowlands
    Member
    Posted 6 months ago #

    It works in a widget and not in a page

  7. Stjohn Rowlands
    Member
    Posted 6 months ago #

    It works in a widget and not in a page

  8. Ross Hanney
    Member
    Plugin Contributor

    Posted 6 months ago #

    Are you sure you have the type parameter set to ajax? Looking at your page now, it doesn't appear to be.

  9. rogerjbos
    Member
    Posted 4 months ago #

    I also have this problem. Calendar is only showing current month. I am using the Widget to show the calendar in the sidebar and I have the Display Event settings set to Calednar Grid - with AJAX. Here is the link to my calendar on the site: http://www.norfield.org/Blog/
    Thanks,

    Roger

  10. rogerjbos
    Member
    Posted 4 months ago #

    Followup: I added a dedicated page in addition to the sidebar I already had and that new page is giving me the same problem, even though I used the type="ajax" parameter, as shown below:
    [google-calendar-events id="1" type="ajax" title="Events on" max="0"]
    Thanks, Roger

  11. Ross Hanney
    Member
    Plugin Contributor

    Posted 4 months ago #

    Hello Roger,

    It looks like you have the "Maximum number of events to retrieve" option (in the plugin feed settings) still set at the default (25). Try increasing it.

  12. rogerjbos
    Member
    Posted 4 months ago #

    Ross,

    You were correct. I still had 25 in the calendar feed. It is working now. The widget also had an option for that and I set it to zero for all events, so I thought I had that base covered, but I guess not. Thanks for such a nice plug-in.
    Thanks, Roger

Reply

You must log in to post.

About this Plugin

About this Topic