WordPress.org

Ready to get started?Download WordPress

Forums

mb.miniAudioPlayer - an HTML5 audio player for your mp3 files
[resolved] Showing link rather than player (8 posts)

  1. ablefingers
    Member
    Posted 1 year ago #

    I have just installed your really cool audio player but had some trouble to trick it into working properly.

    Following the procedure you describe in the video, all I get is a link name on the page. But no player. Clicking on that link opens another page- now with a properly functioning player. The html I get when using this procedure is this:

    Maroon 5 - One More Night

    When I change the URL to this: http://vvvv.vvvvv.org/wp-content/uploads/2012/12/Maroon-5-One-More-Night.mp3
    - than everything works as expected. Like a breeze!

    Is it a bug or have I gone wrong somewhere? Maybe the default settings?

    Cheers, Wolfgang

    http://wordpress.org/extend/plugins/wp-miniaudioplayer/

  2. Grandewd
    Member
    Posted 1 year ago #

    Hi Wolfgang,
    I'm not a member of the support team, but rather another user. I had the same issue, and got it resolved.
    Here's the link to my post here:

  3. Grandewd
    Member
    Posted 1 year ago #

    Link didn't show up above...
    Trying again now:

  4. Grandewd
    Member
    Posted 1 year ago #

    Ok, the link option here seems to not be working.
    Look here in this forum for my post, the details are in it.
    Subject line is "Player doesn't show up in page that uses it."

  5. ablefingers
    Member
    Posted 1 year ago #

    Hi there,
    Many thanks for your reply. Adjusting the Attachment Display Settings of the theme doesn't seem to work in my case. The theme I am using, Yasmin, doesn't offer this option.
    I work around the problem by manually adding the proper URL.

    Thanks again.

  6. Grandewd
    Member
    Posted 1 year ago #

    Are you sure? When you "add or insert" media, on the right hand side you dont' see "Attachment Display Settings" ?

  7. ablefingers
    Member
    Posted 1 year ago #

    Oh, I get it. Apologies for my ignorance.

    My theme doesn't display "Attachement Display Settings" - the thing is labelled differently. Under Link URL I have three choices available: " None", "File URL" and "Attachement Post URL" (which seems to be the default setting in this case).
    Choosing "File URL" produces the correct results for the audio player to function as intended without having to add the URL manually. It all works really nicely.

    Thanks for pointing this out to me. I am fairly new to tricking the "web" into doing what I want. Have the vision but lack the code, but am am learning....

    BTW - would you happen to know how to adjust the player's width when closed. I would need it to be a bit wider when idle so it sits better with the visual design. I figured out how to adjust the width when opened and lots of other stuff but not this.

    Thanks.

  8. charismeki
    Member
    Posted 1 year ago #

    that made it ^^thanks for posting the obvious solution

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.