WordPress.org

Ready to get started?Download WordPress

Forums

Google Language Translator
[resolved] Show Flags in Header of website (26 posts)

  1. deej130
    Member
    Posted 4 months ago #

    Hello,

    I have successfully installed the plugin and chosen my desired flags in the settings menu.

    I would like for these flags to be displayed at the top left of my website's header section, on all pages.

    Please may you advise where exactly I would need to paste <?php echo do_shortcode('[google-translator]'); ?> in my header.php code and also any CSS styles I would need to apply.

    Thanks,

    Dhiraj

    https://wordpress.org/plugins/google-language-translator/

  2. Rob Myrick
    Member
    Plugin Author

    Posted 1 month ago #

    Hi deej130,

    It has been quite some time since your post here. I'm sorry for such a late response.

    I'm the plugin developer and can help you place the translation widget in the correct location, if you still need help.

    I will need to the site in order to do this - however. You can send me a link to your homepage if you want through this form:

    http://www.wp-studio.net/contact/

    Let me know - thanks!

    Rob Myrick

  3. Adhitya Fernando
    Member
    Posted 1 month ago #

    Hi Rob, I'm response to your assitance offer to set the widget position. I have done what Deej did, insert <?php echo do_shortcode('[google-translator]'); ?> in my header.php code and also any CSS styles. But I don't get the position I desire.

    Here is the code I insert in header.php
    <div id="gtranslate">
    <?php echo do_shortcode('[google-translator]'); ?>
    </div>

    And I have also make custom css like .gtranslate {padding-bottom:20px} or .gtranslate {margin-top:20px} but it doesn't make changes.

    Look at this the image preview: http://i988.photobucket.com/albums/af4/Adhitya_Fernando/gtranslate_zps8e651673.jpg My website link is: http://www.adhityafernando.com

    Thank you in advance.
    Regards from Indonesia

    Adhitya Fernando

  4. Rob Myrick
    Member
    Plugin Author

    Posted 1 month ago #

    Hi Adhitya! Thanks for your response.

    I now see your website and position of the widget.

    I will provide the CSS code needed to help you position the widget. Can you please answer the following:

    1) Do you want to show flags, or hide flags?

    2) Do you want to show the language box, or hide the language box?

    3) Where in the header would you like the widget placed?

    If you tell me those 3 things, I can give you exact code to re-position the widget.

    Thanks so much!

  5. Adhitya Fernando
    Member
    Posted 1 month ago #

    Hi Rob,
    Glad to find you very much welcome.

    Here's the answer:
    1. I want to show the flags (5 or 7 flags)
    2. I want to hide language box
    3. Under the logo.

    In the image preview above, you could see that I can display the flags under the logo position. But I don't know why it's position is too down.
    But it's different when I choose to display the language box, the position is fit with the space as you could see in my website now.

  6. Rob Myrick
    Member
    Plugin Author

    Posted 1 month ago #

    Hi Adhitya,

    Ok, let's start by doing these things:

    1) Go to your WordPress Dashboard: "Settings > Google Language Translator"

    2) For "What translation languages will you display to website visitors?" setting, choose "All Languages".

    3) For "Show Flag Images" setting, choose "Yes, show flag images".

    4) For "Select Flag Size" setting, choose "22px".

    5) In the CSS Overrides box, add this CSS:

    #flags ul { margin:0; } .flag { padding:1px 2px; }

    Let me know how that looks when you finish - I think you will like.

  7. Adhitya Fernando
    Member
    Posted 1 month ago #

    Hi Rob,

    Yes I like it. Very awesome, the display is very nice.
    But I need some more costumization, please see this image preview:
    http://i988.photobucket.com/albums/af4/Adhitya_Fernando/GtransROb_zpsc373beba.jpg

    Thank you very much.
    I really appreciate your help

  8. Rob Myrick
    Member
    Plugin Author

    Posted 1 month ago #

    Adhitya,

    I see that you do not have the most current version installed - did you switch back?

    I you can update - I will fix your remaining issue. There is one more CSS conflict with your theme.

    Thanks!

  9. Adhitya Fernando
    Member
    Posted 1 month ago #

    Hi Rob,

    I don't switch back, but I don't know why that there's no update notification from my dashboard for this plugin.

    Now I have already installed the current version (4.0.3), but it makes the flag position vertical, can not set to be horizontal, and also there's a dot before each flag. Here is the preview: http://my.jetscreenshot.com/demo/20140802-tlog-17kb

    Sorry that I make you troublesome :)

  10. Rob Myrick
    Member
    Plugin Author

    Posted 1 month ago #

    Hi Adhitya, I mentioned at top of this forum that this could happen. I'm going to look at your site now and provide fix for you.

  11. Rob Myrick
    Member
    Plugin Author

    Posted 1 month ago #

    Would you mind activating the plugin so that I could provide solution for you? Thank you...and sorry for the inconvenience.

  12. Adhitya Fernando
    Member
    Posted 1 month ago #

    The plugin is been activated, Rob..

  13. Rob Myrick
    Member
    Plugin Author

    Posted 1 month ago #

    Only this is showing to me under your logo:

    [google-translator]

    On this website: http://www.adhityafernando.com/

    Are you sure it's activated?

  14. Rob Myrick
    Member
    Plugin Author

    Posted 1 month ago #

    It is showing as not active on the homepage, but on your blog page it shows as activated.

  15. Adhitya Fernando
    Member
    Posted 1 month ago #

    Yes sure it's activated, look at this recent screenshot
    http://my.jetscreenshot.com/demo/20140802-bjvr-12kb

    But it's different in the dashboard: http://my.jetscreenshot.com/demo/20140802-hqnz-14kb

  16. Rob Myrick
    Member
    Plugin Author

    Posted 1 month ago #

    I see it now......checking :)

  17. Rob Myrick
    Member
    Plugin Author

    Posted 1 month ago #

    Hi Adhitya Fernando, I think this is still old version. Do you have 4.0.3 installed? This is most recent update, and it has important CSS code that will help this issue.

    Please update to 4.0.3 and then let me know and I will look once again.

  18. Adhitya Fernando
    Member
    Posted 1 month ago #

    No Rob, I have version 4.03 installed.
    Look at this: http://my.jetscreenshot.com/demo/20140802-ptjl-18kb

  19. Rob Myrick
    Member
    Plugin Author

    Posted 1 month ago #

    Oh ok I see now - there is some lag time between when you make the change, and when I actually see it.....haha.

    Checking now - it looks better already, but I will fix that last flag for you.

  20. Rob Myrick
    Member
    Plugin Author

    Posted 1 month ago #

    OK, add this to the CSS Overrides box in "Settings > Google Languge Translator":

    #flags {
        width:185px;
    }

    That should do the trick!

    Make sure you add it in that box, so that you won't lose changes on next update.

  21. Adhitya Fernando
    Member
    Posted 1 month ago #

    Haha..yes Rob.

  22. Adhitya Fernando
    Member
    Posted 1 month ago #

    Rob, why it doesn't make change?
    http://my.jetscreenshot.com/demo/20140802-rdho-11kb

    Is there possibility of CSS conflict with my theme, like you told above?

  23. Rob Myrick
    Member
    Plugin Author

    Posted 1 month ago #

    It looks like you have already tried to set the width in another location. Make sure you remove any other CSS you have made to the plugin, and then try this just to make sure:

    #flags {
        width:185px !important;
    }

    Let me know once you do that.

  24. Rob Myrick
    Member
    Plugin Author

    Posted 1 month ago #

    Never mind. I can see that you did not make any other changes, just use the solution above and it should work.

  25. Adhitya Fernando
    Member
    Posted 1 month ago #

    Oh yes I found that I've make css for width in another location, it's deleted now.

    And here is the result! Yuhuuu...I feel so glad.
    http://my.jetscreenshot.com/demo/20140802-slfh-8kb

    Thank you very much Rob!!!!
    I wish you keep on success and prosperous...

  26. Rob Myrick
    Member
    Plugin Author

    Posted 1 month ago #

    Thanks Adhitya! I appreciate your support in using the plugin. Please post if you have any other issues - thanks, Rob

Reply

You must log in to post.

About this Plugin

About this Topic