WordPress.org

Ready to get started?Download WordPress

Forums

Social Author Bio
[resolved] Show Bio on Index.php (Front Page) (3 posts)

  1. Big D
    Member
    Posted 1 year ago #

    Nick,

    How can I have the bio show on the front page? Currently, it only shows on the single post page?

    http://wordpress.org/extend/plugins/social-autho-bio/

  2. Nick Powers
    Member
    Plugin Author

    Posted 1 year ago #

    The answer depends on what you have set in your Reading Settings.

    If it is set to a static page the easiest way would be to add a shortcode for social author bio in that static page.

    If you have it set to show your latest posts then it depends on what exactly you are looking for. Do you want a single Social Author Bio box to appear from one author on that page or do you want a Social Author bio box from each post's author?

    If you want a single Social Author Bio box from a single author to appear on that page then you will want to add the code to the specific template page that serves up that page. Which file to edit will depend upon your theme. If it is a general template file, like index.php, you will want to add a test to make sure it does this only when you are on the home page or you will have it showing up places you don't want. That might look something like this:

    <?php if ( is_home() ) echo do_shortcode('[social-bio id=1]'); ?>

    Make sure you put the code outside the loop or it will repeat for each post. Replace the 1 (in the id=1 above) with the ID of the user you want to display.

    If you want to display a Social Author Bio for each post article then put code like this in the template file (mentioned above) and put it inside the loop:

    <?php if ( is_home() ) echo do_shortcode('[social-bio]'); ?>

    Let me know if this answers your question.

    Nick

  3. Big D
    Member
    Posted 1 year ago #

    Nick,

    Thanks for the reply. It did answer my question. It didn't work at first but then I realized I didn't have the shortcode checked in the settings page. Once I checked it....all worked great! Thank you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.