WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Show Author (6 posts)

  1. wwinegarden
    Member
    Posted 3 years ago #

    Hi,

    Just started writing my blog, and this may be a simple question but it is one that has been niggling at me for some time.

    I have a multi-author blog, how do we get the authors name to show when posting.

    I have been searching the settings but cannot find anything to turn them on... the names not the authors ;)

  2. anttijn
    Member
    Posted 3 years ago #

    It depends on the theme you are using.
    Usually the name of the author is visible under the post title on the same line where the posting date is printed.

    Seeing your blog would help...

  3. Zhou
    Member
    Posted 3 years ago #

    oh since we are under this topic, is it possible to remove the author under the title? coz for me i am the only one writing so displaying the author name seems redundant. Any help? Thanks.

    I using 2010 Weaver theme, site at liferature.com

  4. anttijn
    Member
    Posted 3 years ago #

    Sure you can but it involves editing the theme files.

  5. Digital Raindrops
    Member
    Posted 3 years ago #

    @Zhou,
    The weaver theme is a twenty ten child theme, without a custom loop, the author is returned in a function twentyten_posted_on() which is code in the functions.php.

    So you would have to do this with a stylesheet, by hiding three elements (classes) from two spans, note: 'author' and 'vcard' are two different classes.

    If you view the page source we need to hide the following:
    <span class="meta-sep">by</span> <span class="author vcard">

    1. In the Admin > Appearance > Twenty Ten Weaver
    2. Click on the 'advanced options'
    3. Find the text box <HEAD> Section

    4 Replace:

    <!-- Add your own CSS snippets between the style tags. -->
    <style type="text/css">
    </style>

    With:

    <!-- Add your own CSS snippets between the style tags. -->
    <style type="text/css">
    .entry-meta .meta-sep,
    .entry-meta .author,
    .entry-meta .vcard{
         display:none;
    }
    </style>

    Update Advanced Options and check the website

    We have now hidden the word 'by' meta-sep and the author and vcard, in the entry-meta section.

    HTH

    David

  6. Zhou
    Member
    Posted 3 years ago #

    @Adeptris

    Frankly I do not understand what you are talking about, but I did what you said by replacing the code you provide and it worked. Thanks a lot!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags