WordPress.org

Ready to get started?Download WordPress

Forums

Shortcodes Ultimate
Shortcodes Ultimate 4.4.4 (9 posts)

  1. acastlenut
    Member
    Posted 8 months ago #

    Changed it back to version 4.3.2 and all working again.
    The effect of loading 4.4.4 is the short code buttons disappeared and the code from the button appeared on the web page
    The theme for this web site is Genesis

    This link will show the 4.3.2 plugin at work

    Kind regards

    acastlenut

  2. dccharron
    Member
    Posted 8 months ago #

    For those (like me) who have never tried installing an older version of a plugin before, follow this link:

    http://wordpress.org/plugins/shortcodes-ultimate/download/

    On this page, scroll down and pick an older version. Click on its number and that downloads the zip file to your PC. Then follow these installation instructions:

    Unzip plugin files and upload them under your '/wp-content/plugins/' directory.

    Resulted names will be: './wp-content/plugins/shortcodes-ultimate/*'

    Activate plugin at "Plugins" administration page.

    Remember that older versions can suffer from compatibility issues with core WP updates. So this is a stopgap measure to overcome serious problems you encounter with a new version.

  3. Lisa
    Member
    Posted 7 months ago #

    If you install 4.4.4 again you just have to uncheck Compatibility Mode enabled in settings and it will work again, I'm using on a Genesis child theme also.

  4. myhero
    Member
    Posted 7 months ago #

    @Lisa, that solution did not work for me.

  5. robscott
    Member
    Posted 7 months ago #

    @lisa - yes, that solution tends to work.

    +1 for "Compatibility Mode" going from unchecked to checked on upgrade.

    @myhero If you already used compatibility mode, and you prefixed with "gu_" this recently changed to "su_" which might also be your problem? There is a functions.php fix for this, but you could also find and replace gu_ with su_ site-wide.

  6. akingsail
    Member
    Posted 7 months ago #

    I have learned a valuable lesson from this upgrade which does not work. I have lost buttons, tabs, tables and other stuff on a very large site, creating a huge amount of work. I cannot see the point in upgrading what was a very useful plugin to one which is now totally useless. I do not intend wasting any more time with it. I appreciate it is free, but I would have been happy to pay for this, if it worked.

  7. robscott
    Member
    Posted 7 months ago #

    @akingsail This plugin has stopped working upon upgrade more than once - I would recommend you don't upgrade in production website unless you are able to quickly troubleshoot your website. It is possible to update all your shortcodes on the fly, but this is a very advanced feature, which perhaps goes beyond what can reasonably be expected of a WordPress webmaster.

    As a first port of call, I would recommend backing up and restoring your backup, OR, rolling back to the previous version of the plugin which WAS working.

    Always backup before upgrading plugins because things CAN and DO break on upgrade.

  8. akingsail
    Member
    Posted 7 months ago #

    Thanks robscott for the wise advice, and I will certainly backup in future. This is the first time this has happened so I guess I am lucky. The other lesson I have learned is if it can be coded, code it. 'Time saving' plugins like this one are potentially able to deliver a 'sting in the tail'. Rolling back to a previous version is an option. However, I am now very wary, and coding buttons, tables, tabs etc., is not rocket science, and seems the preferable answer.

  9. robscott
    Member
    Posted 7 months ago #

    @akingsail - hand coding can be the way to go if you can handle it. We use shortcodes plugin where the person updating is less advanced, and it is largely successful. Recent upgrades have pushed the plugin around quite a lot. This was necessary in my view as theme compatibility (and compatibility with other plugins) will become an issue with shortcodes very quickly - particularly with premium themes.

    Remember, with open source, sometimes we're bleeding edge. Always worth being prepared to roll back, although updates will usually work if done sequentially. In particular, watch out if you're on, say, version 1.2.3 and the new plugin when you login is 1.4.8 or something (i.e. a lot of versions between where yours is and where the new version is).

Reply

You must log in to post.

About this Plugin

About this Topic