WordPress.org

Ready to get started?Download WordPress

Forums

Shortcodes Not Working (7 posts)

  1. Patrick Daly
    Member
    Posted 5 years ago #

    Below are two examples of shortcodes being used in my site and not working. Rather than doing what they're supposed to do the shortcode displays. I've reinstalled WP twice, and no fix. I think it must be something in the database, but any other thoughts?

    http://developdaly.com/about/
    http://developdaly.com/crowne-plaza-invitational-colonial/149/

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Try disabling your plugins, see if the problem goes away. One of the plugins you are using may be interfering with the shortcodes.

  3. Patrick Daly
    Member
    Posted 5 years ago #

    I did that and nothing changed. Any other suggestions?

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    You haven't disabled your plugins, because at least one of them is still running. PodPress, to pick an example.

    No, I don't think PodPress is the cause, but my point is that until you try, you don't know. Also, you're using WP-Cache, so make sure that you clear your caches after disabling the plugins to make sure you're seeing a fresh page.

  5. Patrick Daly
    Member
    Posted 5 years ago #

    No, I DID disable them, and then I enabled them once that proved that it wasn't the problem.

    I also cleared my cache.

    It can't be a plugin, unless it's something a plugin did to the DB.

  6. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    It has nothing to do with the database. Shortcodes are performed in the actual core WordPress code, not in the database.

    There's only two possible explanations:
    1) You're not running a version of WordPress that actually has shortcodes.
    2) You have a plugin or theme that intentionally disabled the shortcodes.

  7. Patrick Daly
    Member
    Posted 5 years ago #

    Otto, thanks for all your help.

    After I deactivated all of my plugins I checked a page with an incorrectly formatted shortcode so nothing seemed fixed.

    I deactivated them all again and checked another page it worked.

    It turns out the culprit was Google Website Optimizer for WordPress.

    Thanks again!

Topic Closed

This topic has been closed to new replies.

About this Topic