WordPress.org

Ready to get started?Download WordPress

Forums

amr shortcode any widget
[resolved] Shortcodes empty or not defined. (4 posts)

  1. mrusselr
    Member
    Posted 1 year ago #

    Hi,

    Firstly, awesome plugin!

    I seem to be having an issue when updating a page that has a Shortcode tag in it. It updates the page when I check the site and the actual webpage is fine. However after clicking the "Update" button instead of reloading with the normal success message I just get a page with this message "Sidebar Shortcodeswith sidebarid Shortcodes empty or not defined.
    Widget not in sidebar with id Shortcodes and with name Shortcodes
    ".

    I am at a loss. The widget is correctly placed in the Shortcodes section in the Widget area, and it has been working fine until the last couple of days. Just updated to 3.4.2 - not sure if that's the issue, otherwise have had no other updates.

    Any ideas? I am at a loss here.

    http://wordpress.org/extend/plugins/amr-shortcode-any-widget/

  2. anmari
    Member
    Plugin Author

    Posted 1 year ago #

    How weird. Sounds like somehow the shortcode is being run before the sidebars are available.

    Ii was tested on 3.4.2 but I couldn't swear that new pages with shortcodes were created - may have tested that existing ages work.

    I'm wondering whether wp does something on update (runs shortcodes etc) and maybe at that time the sidebars aren't setup by wp ?

    Does it only do it on post update BUT when viewing page externally it is okay?
    Is it a theme thing ? ie is it okay on default wp theme?
    Any caching plugins that might be doing something?

    I can't check myself right now, will try later.

  3. mrusselr
    Member
    Posted 1 year ago #

    Hi,

    Thanks for your reply.

    It's a strange one. I have discovered it's related to the theme (not sure where - it's not my theme). I tried it on one of my themes and it's fine.

    Basically yes, it's only doing it on post update, viewing the page externally has no issues at all. Even the widget debug shows the sidebar correctly. Only happens when you do a post update on a page that has a shortcode tag in it.

    I'm going through the theme now trying to find anything. If you have any ideas, that would be great.

    Thanks so much.

  4. anmari
    Member
    Plugin Author

    Posted 1 year ago #

    Hi - the theme may be trying to do some processing on the content of a page/post - check any add_filter or add_action statements.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.