WordPress.org

Ready to get started?Download WordPress

Forums

Photonic Gallery for Flickr, Picasa, SmugMug, 500px, Zenfolio and Instagram
[resolved] Shortcode Syntax [Gallery] is conflicting with theme shorcode (17 posts)

  1. cirjegan
    Member
    Posted 1 year ago #

    HI,

    Shortcode Syntax [Gallery] is conflicting with the premium photography theme. is it possible to change the shortcode like [pgallery type='smugmug' view='albums' nick_name='nick-name'].

    Thanks

    http://wordpress.org/extend/plugins/photonic/

  2. Sayontan Sinha
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry, I cannot do that. I have a pretty big user base, and if I change the syntax I will be breaking the sites of thousands of users.

  3. cirjegan
    Member
    Posted 1 year ago #

    Hi, Thanks for your fast response. Can you give any idea of doing that. that will be very helpful for me.

  4. Sayontan Sinha
    Member
    Plugin Author

    Posted 1 year ago #

    Can't say for sure. In the file photonic.php there is a line:

    add_filter('post_gallery', array(&$this, 'modify_gallery'), 20, 2);

    Try changing it to something like:

    add_shortcode('pgallery', array(&$this, 'modify_gallery'));

  5. cirjegan
    Member
    Posted 1 year ago #

    Thanks. But i have changed the shortcode of theme gallery to gallery1. And now your plugin is working fine. But a problem. when i see the albums the photos inside the album are showing in lightbox as thumbnails but when i click the thumbnail a new lightbox is opening and not displaying any image. when i check into the code. i found the href for that anchor tag is passing null. can you please check that.

    Code:

    <img src="http://rishithukralphotography.smugmug.com/Events/Harsha-Roha-Pooja/i-cSkjbXm/1/Th/Pooja_001-Th.jpg" alt="">

  6. Sayontan Sinha
    Member
    Plugin Author

    Posted 1 year ago #

    Your pasted URL didn't come across correctly. Please re-paste it using &lt; instead of <

  7. cirjegan
    Member
    Posted 1 year ago #

    <a rel="lightbox-photonic-smug-stream-1" class="launch-gallery-colorbox colorbox photonic-pad-photos cboxElement" href=""><img src="http://rishithukralphotography.smugmug.com/Events/Harsha-Roha-Pooja/i-cSkjbXm/1/Th/Pooja_001-Th.jpg" alt=""></a>

  8. cirjegan
    Member
    Posted 1 year ago #

    Yes. Thats the problem. Why its not coming correctly. the link will be generated dynamically right.

  9. Sayontan Sinha
    Member
    Plugin Author

    Posted 1 year ago #

    What is your site's URL? I need to visit a page to help you here.

  10. cirjegan
    Member
    Posted 1 year ago #

    Sorry. Working in local. Will Upload and let you know. Also is there any way to hide the password protected galleries. it is showing as Empty Gallery now.

  11. Sayontan Sinha
    Member
    Plugin Author

    Posted 1 year ago #

    I think the link is getting corrupted by either your theme or another plugin. When I see the CSS class, something is adding the "cboxElement" class for you - Photonic doesn't do that. Whatever is changing the class, it is likely that it is also removing the href.

  12. cirjegan
    Member
    Posted 1 year ago #

    "cboxElement" class is adding when i m using colorbox. if i use fancybox then its changing to fancybox

  13. Sayontan Sinha
    Member
    Plugin Author

    Posted 1 year ago #

    OK. In any case, I will need to see your site for this - something is corrupting the link and it is not Photonic. Does your theme come with a lightbox library of its own?

    If you want I can put up your photos on the demo page temporarily to show you that it will work.

  14. cirjegan
    Member
    Posted 1 year ago #

    The Problem is solved. I Selected Original in Expanded size. so its coming as null. When i select large its coming nice.

    A Small problem remaining is there a way to hide password protected galleries. It is now showing as empty gallery

  15. Sayontan Sinha
    Member
    Plugin Author

    Posted 1 year ago #

    I will add an option for that in the next release.

  16. cirjegan
    Member
    Posted 1 year ago #

    Thank you very much for all your early and fast replies. For the time till next release. I can make that by selecting privacy in gallery settings as unlisted.

    Then we can avoid displaying empty gallery like that.

    Once again thanks for your response.

  17. cirjegan
    Member
    Posted 1 year ago #

    Thanks for your replies. This Thread is resolved

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.