WordPress.org

Ready to get started?Download WordPress

Forums

Advanced iFrame
[resolved] Shortcode source param not working. (18 posts)

  1. creativ1ne
    Member
    Posted 1 year ago #

    I have "allow shortcode attributes" set to yes... I am on WordPress 3.5 with the 2.0.1 download of this plugin. I have no default url defined and am using this with no luck.

    [advanced_iframe securitykey="key#" src="http://www.sitename.com"]

    The plugin never picks up the src url. Just loads blank page.

    http://wordpress.org/extend/plugins/advanced-iframe/

  2. mdempfle
    Member
    Plugin Author

    Posted 1 year ago #

    I check if the attribute reading has changes in 3.5 somehow...

  3. quambo
    Member
    Posted 1 year ago #

    I've got the same issue, any idea? Thanks ;)

  4. mdempfle
    Member
    Plugin Author

    Posted 1 year ago #

    I'll check the code tonight.
    So if there is a problem a update will be available tomorrow.

    But for now simply add the url in the administration.

  5. quambo
    Member
    Posted 1 year ago #

    It works just fine in the admin area, thanks.

  6. mdempfle
    Member
    Plugin Author

    Posted 1 year ago #

    I tested with

    [advanced_iframe securitykey="key" src="http://www.spiegel.de"]

    and it works fine. It does not matter if I had a src in the administration or not.
    Allow shortcode attributes is set to "yes".

    I have tested with WP 3.5

  7. mdempfle
    Member
    Plugin Author

    Posted 1 year ago #

    This also can happen if the page does now allow you to include it in a iframe.
    See http://wordpress.org/support/topic/sub-domain-not-showing-up?replies=3

  8. karan81
    Member
    Posted 1 year ago #

    Same here, src=" " does not work even if the "allow shortcode attributes" is set to yes

  9. mdempfle
    Member
    Plugin Author

    Posted 1 year ago #

    what does happen? is the url from the administration shown?

    check the shortcode text in text mode of your editor. Sometimes if you e.g. copy the shortcode from the settings html stuff is copied as well!.

  10. karan81
    Member
    Posted 1 year ago #

    I checked my spellings, codes - all are fine.
    The shortcode just appears as it is on the page.

    However the default shortcode with the default url typed in the settings, appears ok and good with perfect height.

  11. mdempfle
    Member
    Plugin Author

    Posted 1 year ago #

    So if you remove the src it works? can you please post your shortcode?

  12. karan81
    Member
    Posted 1 year ago #

    yes if i remove src it works.
    Code i am usign is - [advanced_iframe securitykey="realcodes" src="http://www.something.coom "]

  13. mdempfle
    Member
    Plugin Author

    Posted 1 year ago #

    I have this like this on most of my demos because I have several iframes. So the src attribute does work on 3.4.3 for sure.
    Have you entered the shordcode in the plain text mode of the editor also?

    I have found out that e.g. any html characters around also forces WordPress to ignore the shortcode.

  14. mdempfle
    Member
    Plugin Author

    Posted 1 year ago #

    Which version of WordPress and of the plugin do you use?
    Maybe you have another plugin that somehow disallow certain attributes...

  15. karan81
    Member
    Posted 1 year ago #

    I am using latest wordpress and your latest 3.4.3. May be it might conflict with some other plugins.

    I use HTML editor while creating page and I know a bit of programming too to so I am careful using shortcodes.

    Thanks anyway. By they way great plugin the auto height feature was what I was looking for.

  16. mdempfle
    Member
    Plugin Author

    Posted 1 year ago #

    Can you use the plain text editor?

  17. karan81
    Member
    Posted 1 year ago #

    Yes I used the plain text editor

  18. mdempfle
    Member
    Plugin Author

    Posted 1 year ago #

    I cannot reproduce your problem. The only thing I can offer you is to look at you installation. Please go to the forum of TinyWebGallery and send me a pm.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic