WordPress.org

Ready to get started?Download WordPress

Forums

Audio Player
shortcode not working properly (6 posts)

  1. mrbbfs
    Member
    Posted 8 months ago #

    If I enter the below code, player works when I push play:
    [audio:http://www.YourAudioURL.mp3]

    BUT, when I do the below, it says "file not found":
    [audio:http://www.YourAudioURL.mp3|autostart=yes|loop=yes]

    Whats Up?

    http://wordpress.org/plugins/audio-player/

  2. robhob
    Member
    Posted 8 months ago #

    I've just had the same problem. The code that WordPress was inserting looked like this:
    [audio mp3="http://kempstonrecruitment.co.za/wp-content/uploads/2013/12/temping.mp3"][/audio]

    The problem was fixed by changing it to this:
    [audio:http://kempstonrecruitment.co.za/wp-content/uploads/2013/12/temping.mp3]

    Also, do you self a favour and pasting the URL you're using into your browser and see if your browser finds the file.

  3. mrbbfs
    Member
    Posted 8 months ago #

    I can get it to play, but I want it to autostart and then loop. when I add the parameters at the end (autostart=yes|loop=yes), that is when I get the file not found. something is amiss about the end parameters

  4. robhob
    Member
    Posted 8 months ago #

    I've disabled the Audio Player plugin and am busy switching to the built-in audio player. The plugin is flash based and doesn't work on mobile devices.
    https://codex.wordpress.org/Audio_Shortcode
    http://twelvetwo.net/wordpress-3-6-audio-autoplay/

  5. mrbbfs
    Member
    Posted 8 months ago #

    Ditto, I went with another also. Free version works fine for one track at a time, pay version lets you put in multiple at once. Seems to work fine...autostart does not work on mobile, you actually have to select play for it to work though.

    http://www.tsplayer.com/audio-and-video-player

  6. robhob
    Member
    Posted 8 months ago #

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.