WordPress.org

Ready to get started?Download WordPress

Forums

WP Photo Album Plus
[resolved] shortcode inserts post address help! (8 posts)

  1. Kip Carter
    Member
    Posted 1 year ago #

    I've gotten my mind around the add in far enough to being using shortcodes and what I'm finding is that the posting that I use the shortcode gets inserted into the url in the link and fails to load due not being found there.

    Example:
    [wppa album=1][/wppa] takes my browser to:
    http://thecartersandfriends.com/gallery/welcome-enjoy/?wppa-album=2&wppa-cover=0&wppa-occur=1

    If I edit the url and re-enter like this it works:
    http://thecartersandfriends.com/gallery/?wppa-album=2&wppa-cover=0&wppa-occur=1

    Taking out the welcome-enjoy/ fixes it. But I can't expect my users to edit every click. Thoughts?

    Regards,
    Kip...

    http://wordpress.org/extend/plugins/wp-photo-album-plus/

  2. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 1 year ago #

    You did 'funny' things with the permalink of this page.
    Pressing the title of the page: Welcome... enjoy! produces the same 404 error. If you fix the pages permalink, the links from the wppa shortcode will also be fixed.

  3. Kip Carter
    Member
    Posted 1 year ago #

    Not sure what I did or how I did it to do that.. I will go back in and see if I can see something that I may have altered. Been pretty careful not to upset things. If that is the case I could just wipe and start fresh too.

    I'll let ya know what I come up with. Thanks.

    Regards,
    Kip...

  4. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 1 year ago #

    Just delete the page, create a new one, do not change the permalink, add the shortcode, done!

  5. Kip Carter
    Member
    Posted 1 year ago #

    I did more than that.. wanted to be absolutely sure I wasn't altering anything.. so I cleared the WordPress install completely. Then installed the add in on the new install.

    I then deleted all exiting pages and posts.

    Then I edited my first post and sure enough the shortcode at the top of the page inserted the words n the title into the shortcode. I previewed and it worked just fine. Published and again the text was inserted that prevented it from pulling up the link. Remove that text and it works.

    So I removed the post and did another without the title field filled in. it put in the number 15 rather than text and performed exactly the same in preview and publish.

    I'm baffled... the ONLY issue is getting the links to work correctly. everything looks perfect otherwise. So frustrating.

  6. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 1 year ago #

    You may send me admin login data ( mail to opajaap at opajaap dot nl ) and i will help you out.

  7. Kip Carter
    Member
    Posted 1 year ago #

    That would be tremendous if you could. I have it currently disabled as I was examining if there was any other means of doing this I will re enable and create an admin account for you on it then send you the email.
    Thanks much!!
    Kip...

  8. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 1 year ago #

    Fixed by changing wp permalink structure to a preset value ( post )

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic