WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Shortcode Embeds feature for audio not working in posts (13 posts)

  1. David Burkhart
    Member
    Posted 5 months ago #

    I cannot seem to get any posts to work with the "audio" shortcode. I can use them in a "page" just fine. But, when added to the content of a post, the post URL shows a blank page.

    I do not see any error messages. So, I checked the source code of the resulting post page, both with and without the audio shortcode. Without it, everything shows up fine with 110 lines of code for the head. After inserting an audio tag, the head is down to about 50 lines of code and only this one line for the body, "<body style></body>".

    http://wordpress.org/plugins/jetpack/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 5 months ago #

    Could you try to install this small plugin, and let me know if it helps?
    http://i.wpne.ws/M7Le

  3. David Burkhart
    Member
    Posted 5 months ago #

    Mr. Herve,

    Sorry for the delay. That one-liner plugin did the trick.

    Thank you.

    Any chance that I soon will no longer need your plugin? Or, am I going to need to hang onto this for a while?

  4. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 5 months ago #

    Any chance that I soon will no longer need your plugin? Or, am I going to need to hang onto this for a while?

    I'm afraid we still haven't been able to fully understand what's causing the issue. A few other Jetpack users have reported similar issues, but it seems limited to a small set of Jetpack sites with a specific configuration.

    Would you mind trying to install this patched version of Jetpack on your site, instead of the current Jetpack plugin?
    https://cloudup.com/cT1JzUjV68V

    Once you've done so, deactivate the small plugin I gave you earlier and let me know if the problem still appears.

    Thanks!

  5. David Burkhart
    Member
    Posted 5 months ago #

    Mr. Herve,

    I am able to see a graphic for a zip file at that address. But, the link for downloading it does nothing. Permissions problem perhaps?

  6. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 5 months ago #

    Try this link instead:
    http://i.wpne.ws/Tfuc

  7. David Burkhart
    Member
    Posted 5 months ago #

    I tried the modified version of 2.7 you posted with your disabler plugin deactivated. The problem still occured. However, after upgrading Jetpack to 2.8, your disabler plugin still fixes or hides the problem.

  8. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 5 months ago #

    Hi David! I'm not sure I understood your last reply there. Is Jerem'y patch still fixing the issue for you or not?

  9. David Burkhart
    Member
    Posted 5 months ago #

    Yes, the plugin patch still works. The modified version of WordPress 2.7, which I presume to have an integrated patch, did not work.

  10. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 5 months ago #

    Thanks for trying. I'll dig into it further, and post again here as soon as I have some news.

  11. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 4 months ago #

    I wanted to let you know that We've worked on a fix, and will include the change in the next Jetpack release. That should fix the errors you experienced.

  12. David Burkhart
    Member
    Posted 4 months ago #

    Thank you for the kind update. The GitHub conversation makes it sound as if the "audio" shortcode will be dropped. Although, that would fix the error, I doubt that is what is meant by it.

  13. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 4 months ago #

    The GitHub conversation makes it sound as if the "audio" shortcode will be dropped

    If you use WordPress 3.6 or later, you already don't use Jetpack's audio shortcode anymore. You're using WordPress Core Audio shortcode.

    The errors were in fact not caused by Jetpack's Audio shortcode, but by the function extracting content from your posts to build Open Graph meta tags. This function was trying to grab information from Jetpack's Audio shortcode, although it's not in use anymore, as I mentioned above.

    That's also why the small plugin I linked to earlier fixed the problem: ti was deactivating Jetpack's Open Graph meta tags.

    I hope this clarifies things a bit.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.