WordPress.org

Ready to get started?Download WordPress

Forums

Visualizer
[resolved] Shortcode does not turn into graph (20 posts)

  1. ghulst
    Member
    Posted 9 months ago #

    I have just built a nice graph. A pie chart, based on a CSV and it all looked great in the media uploader. But when I chose "insert chart" it placed the shortcode and nothing happened. When I go to the site, the chart does not show.

    Any thoughts?

    http://wordpress.org/plugins/visualizer/

  2. madpixels
    Member
    Plugin Author

    Posted 9 months ago #

    Does your theme have <?php wp_footer() ?> call in the footer.php file?

  3. ghulst
    Member
    Posted 9 months ago #

    Yes, it does.

  4. madpixels
    Member
    Plugin Author

    Posted 9 months ago #

    give me a link on a page where your graph should appear.

  5. ghulst
    Member
    Posted 9 months ago #

    Sure. I have just added a page with the graph on it:

    http://www.onl.nl/poll-results

  6. madpixels
    Member
    Plugin Author

    Posted 9 months ago #

    Looks like you use cache W3 Total Cache plugin. Could you clear your cache?

    Or could you disable W3 Total Cache at all and check if graphs are displayed or not?

  7. ghulst
    Member
    Posted 9 months ago #

    Clearing the cache does not change anything. I cannot switch off W3 Total cache on the live site. Will try it on the testing server.

  8. ghulst
    Member
    Posted 9 months ago #

    Ok, I put it on our testing server, but it does not work there either. That has W3 Total Cache switched off.

    http://staging.onl.nl/poll-graph-test-results

  9. madpixels
    Member
    Plugin Author

    Posted 9 months ago #

    Could you send me the content of your footer.php file via this form? I will take a look at it.

  10. ghulst
    Member
    Posted 9 months ago #

    Done madpixels. Check your mail.

  11. vitaliss
    Member
    Posted 8 months ago #

    Same problem here. Running it on wordpress mulitsite.

  12. madpixels
    Member
    Plugin Author

    Posted 8 months ago #

    @vitaliss

    Does your theme call <?php wp_footer() ?> before closing body tag?

  13. vitaliss
    Member
    Posted 8 months ago #

    </div>

    <?php wp_footer(); ?>

    </body>

    </html>

  14. madpixels
    Member
    Plugin Author

    Posted 8 months ago #

    Give me a link on a test page.

  15. vitaliss
    Member
    Posted 8 months ago #

    I've already uninsulated it and used google spreadsheet to make a html5 chart...

  16. madpixels
    Member
    Plugin Author

    Posted 8 months ago #

    ok

  17. Sajonara
    Member
    Posted 6 months ago #

    Actually I have the same problem. And I'm using W3 Total Cache and an Genesis child theme I adapted to my use.

    Here's a link to a page where I added a visualization, but it does not work. Seems to me that some javascript is missing, because the div with the visualization's id is created but not filled with anything.

    Genesis is calling wp_footer correctly but I exchanged the standard wordpress jquery file with an external loading from google. And that one loads from the bottom of the page.

    http://www.ichspiele.cc/steam-jetzt-mit-75-millionen-aktiven-nutzern-46085/

  18. madpixels
    Member
    Plugin Author

    Posted 6 months ago #

    @Sajonara

    Could you please deactivate W3 Total Cache plugin, clear its cache and recheck if the chart is rendered? Please, let me know how it works without W3TC.

    Thanks

  19. Sajonara
    Member
    Posted 6 months ago #

    Sorry I'd have to say but it did not help.

    Did you rely with your plugin on any of wordpress' standard hooks or js files? For example I deregistered jquery but added a newer version myself.

    Recently I recognized another plugin that stopped working because of this, a carousel. I got it to work though. But with your plugin it did not work in the first place. Is there a possibility that I can load a particular js file for myself that might repair the situation?

    Kind regards,

    Alexander

  20. madpixels
    Member
    Plugin Author

    Posted 6 months ago #

    Hi @Sajonara

    Could you please re-create test chart on a page of your site? I need to look at it again.

    Regards,
    Eugene

Reply

You must log in to post.

About this Plugin

About this Topic