WordPress.org

Ready to get started?Download WordPress

Forums

Challonge
[resolved] Shortcode bug (9 posts)

  1. Theopt
    Member
    Posted 5 months ago #

    [challonge subdomain="my_sub"]

    This shortcode isnt showing all tournaments but only first 5 we've hosted.

    https://wordpress.org/plugins/challonge/

  2. zavaboy
    Member
    Plugin Author

    Posted 5 months ago #

    If by first 5 you mean your latest 5 (with the last tournament on top), then that is the correct behavior, but perhaps not the desired. I will add an attribute to configure the limit in my next update. I feel I was intending to add this, but it somehow slipped by. So, yeah, sorry for that.

    Thanks for your feedback! :)

  3. Theopt
    Member
    Posted 5 months ago #

    The problem is that its not the latest 5. but actually the first 5 :x We've hosted 9. and it shows from 1 to 5

  4. zavaboy
    Member
    Plugin Author

    Posted 5 months ago #

    That's strange. Have all of the tournaments been created with exactly the same settings, notably the setting to publicly list them?

  5. Theopt
    Member
    Posted 5 months ago #

    Well, is there a way to check now after finished? All the advanced settings are the same.

  6. zavaboy
    Member
    Plugin Author

    Posted 5 months ago #

    If the advanced settings for all tournaments are the same, as you said, then there's something else going on. Would you be so kind to share the subdomain you are using? If you don't want to post it here, you are free to email it to me. My email is my username as you see it on the left, followed by @gmail.com .

  7. Theopt
    Member
    Posted 5 months ago #

    subdomain: Strife HQ
    http://strifehq.challonge.com/

  8. zavaboy
    Member
    Plugin Author

    Posted 5 months ago #

    Alright, I've been able to reproduce the issue. It looks like it may have been a change in the way Challonge sorts tournaments via API. My older listings are in correct order, which is why I started with the questions. I would like to thank you for all your patience, it really helps. :) When I find some time to do it, I will look into making a fix for this.

    I'll post here again once I have it fixed. :)

    Thanks again for your help!

  9. zavaboy
    Member
    Plugin Author

    Posted 5 months ago #

    This has been fixed in version 1.1.0.

    Thanks!

Reply

You must log in to post.

About this Plugin

About this Topic