WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
[resolved] Short code not working (8 posts)

  1. arturocivit
    Member
    Posted 1 year ago #

    I placed the short code in the contact page the output is that code not the form, you can see that here:

    http://thenewmediastudio.com/dev/erin/wordpress/contact/

    Something is going wrong with the plugin, so started to research and came to the hook ups, I checked and my hook ups are in place:

    <?php wp_head(); ?>
    
    </head>

    Any extra help would be much appreciated,

    Thanks a lot in advance!

    Arturo

    http://wordpress.org/extend/plugins/contact-form-7/

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Can you replicate the problem using the default theme with all other plugins deactivated?

  3. arturocivit
    Member
    Posted 1 year ago #

    Hi Esmi, thanks for the reply, I only have those 2 plugins active, one question because I'm fairly new to this, I should be easily switching between themes right? no problem activating the default ones and then switching back to the custom one?

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    no problem activating the default ones and then switching back to the custom one?

    Nope. There should be no problems.

  5. arturocivit
    Member
    Posted 1 year ago #

    Nope. There should be no problems.

    All right, did what you suggested and found this:

    The contact page works, I mean, the form is rendered properly, the slideshow acts the same way it is acting now, just it loads the first image and stops there.

    Not sure what's going on,

    Thanks so much!

  6. arturocivit
    Member
    Posted 1 year ago #

    Maybe the problem is not coming form header nor footer, what about if comes from teh center?

    For example

    <?php
    /*
    Template Name: Home Page
    */
    ?>
    <?php get_header(); ?>
    
    <!--BEGIN CONTENT -->
    
    <div id="container">
    <?php include('comms.php'); ?>
    
    <div id="content-container">
    
    <?php if ( function_exists('show_nivo_slider') ) { show_nivo_slider(); } ?>
    
    <div id="content">
    <div id="PageTitles">RANDE TURNER FEATURED PROPERTIES</div>
    
    <p>
    
    <?php
    global $post;
    $args = array( 'numberposts' => 9, 'category' => 5, 'orderby' => 'rand' );
    $myposts = get_posts( $args );
    foreach( $myposts as $post ) :	setup_postdata($post); ?>
    
    <div id="FeaturedPropery">
    <a href="<?php the_permalink(); ?>" border="0"><?php the_post_thumbnail('mycustomsize'); ?></a>
    <br />
    <?php echo get_post_meta($post->ID, 'Community', true); ?> | <?php echo get_post_meta($post->ID, 'Price', true); ?> | <?php echo get_post_meta($post->ID, 'Status', true); ?>
    </div>
    <?php endforeach; ?>
    
    </p>
    
    <div id="VideoProperty">
    
    <?php query_posts('cat=3&showposts=1&offset=0&orderby=rand'); ?>
    <?php if ( have_posts() ) : while ( have_posts() ) : the_post(); ?>
    <?php the_content(); ?>
    <?php endwhile; endif; ?>
    
    </div>
    
    </div>
    
    <?php get_sidebar(); ?>
    
    <div id="Bios"><img src="<?php print IMAGES; ?>/Bios.png" width="1066" height="167" border="0" usemap="#Map3">
      <map name="Map3">
        <area shape="rect" coords="129,87,248,98" href="mailto:rande@randeturner.com">
        <area shape="rect" coords="129,104,237,115" href="http://randeturner.com">
        <area shape="rect" coords="393,88,502,99" href="mailto:erin@randeturner.com">
        <area shape="rect" coords="392,105,500,115" href="http://randeturner.com">
        <area shape="rect" coords="661,86,781,98" href="mailto:kerryk@randeturner.com">
        <area shape="rect" coords="661,105,768,115" href="http://randeturner.com">
        <area shape="rect" coords="926,87,1037,98" href="mailto:sarah@willisallen.com.com">
        <area shape="rect" coords="927,105,1037,115" href="http://randeturner.com">
      </map>
    </div>
    
    <div id="BlogTwNewsBox">
    <div id="clear-center-image"><img src="<?php print IMAGES; ?>/NewsBanner.png" width="1065" height="79"></div>
    <div id="clear-center-image"><img src="<?php print IMAGES; ?>/LatestBlogEntries.png" width="294" height="64"></div>
    
    <div id="BlogRoundBox">
    
    <?php
    global $post;
    $args = array( 'numberposts' => 6, 'category' => 4 );
    $myposts = get_posts( $args );
    foreach( $myposts as $post ) :	setup_postdata($post); ?>
    
    <!-- Begin Post -->
    
    <div class="BoxBlog">
    <?php the_post_thumbnail('BlogImagesThumb', 'class=alignleft'); ?>
    <b><?php the_title(); ?></b>
    <?php the_excerpt(); ?>
    </div>
    
    <?php endforeach; ?>
    
    <!-- End Post -->
    
    </div> 
    
    <div id="clear-center-image"><img src="<?php print IMAGES; ?>/LatestTweets.png" width="229" height="61" /></div>
    
    <div id="TweetRoundBox">
    <?php
    include_once(ABSPATH . WPINC . '/feed.php');
    $rss = fetch_feed('https://api.twitter.com/1/statuses/user_timeline.rss?screen_name=randeturner');
    $maxitems = $rss->get_item_quantity(4);
    $rss_items = $rss->get_items(0, $maxitems);
    ?>
    
    <ul style="list-style: disc;">
    <?php if ($maxitems == 0) echo '<li>No items.</li>';
    else
    // Loop through each feed item and display each item as a hyperlink.
    foreach ( $rss_items as $item ) : ?>
    <li>
    <a href='<?php echo $item->get_permalink(); ?>' class="NewsBoxLink">
    <?php echo $item->get_title(); ?>
    </a>
    </li><br />
    <?php endforeach; ?>
    </ul>
    </div>
    
    </div>
    
    <div id="Logos">
    <div id="LogoItem"><img src="<?php print IMAGES; ?>/Logo/Luxury.jpg" width="183" height="132"></div>
    <div id="LogoItem"><img src="<?php print IMAGES; ?>/Logo/LuxuryPort.jpg" width="183" height="132"></div>
    <div id="LogoItem"><img src="<?php print IMAGES; ?>/Logo/Regent.jpg" width="264" height="132"></div>
    <div id="LogoItem"><img src="<?php print IMAGES; ?>/Logo/LeadinRealState.jpg" width="128" height="132"></div>
    <div id="LogoItem"><img src="<?php print IMAGES; ?>/Logo/Willis.jpg" width="128" height="132"></div>
    </div> <!-- End Logos -->
    
    </div>
    </div>
    
    <!--END CONTENT -->
    <?php get_footer(); ?>

    Thanks so much!

    Arturo

  7. esmi
    Forum Moderator
    Posted 1 year ago #

    What theme are you using? Where did you download it from?

  8. arturocivit
    Member
    Posted 1 year ago #

    Hi, good morning, using a custom theme.

    i fixed the shortcode thing so now the contact form is properly working, wasn't using the right loop, hence, the code wasn't fully working but now it is fixed,

    Thanks so much for your help!

    Arturo

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.