WordPress.org

Ready to get started?Download WordPress

Forums

HMS Testimonials
[resolved] short code for page does not work (9 posts)

  1. singhwise
    Member
    Posted 10 months ago #

    I've used the [hms_testimonials] shortcode in my page WYSIWYG content area and it won't display any testimonials.

    The side bar widget works perfectly.

    Any ideas why it won't work?

    http://wordpress.org/plugins/hms-testimonials/

  2. Jeff K
    Member
    Plugin Author

    Posted 10 months ago #

    Can you post a link to your site?

  3. singhwise
    Member
    Posted 10 months ago #

    I was just about to post a link but I figured it out.

    The page was actually assigned as a 'display blog posts' page. This is why it wasn't showing any testimonials. I've made the amendments and now it's working fine.

    Awesome plug-in.

    Thanks :)

  4. zucci2
    Member
    Posted 10 months ago #

    Hello!

    I installed your plugin today as what looks like a great solution to my client's need for simple testimonial manager with flexibility. However, I am having trouble as singhwise mentioned above. However, my shortcode appears on a test post and not a page.

    http://elizabethficocelli.com/wpdev/shower-heavenly-roses/

    I have placed this shortcode [hms_testimonials_rotating group="1"] on my post beneath "Reader's Say:". My Group 1 contains about 8 testimonials with source. My site is This is the 3.6.1 WP and the latest Minimal template from Elegant Themes.

    I have the widget working on the home page.

    Thanks for any help you can provide.

  5. Jeff K
    Member
    Plugin Author

    Posted 10 months ago #

    This is a normal WordPress post right? Not like an archive page?

    In your admin, go in and view the group. Groups then click the group ID. On the right hand side there is a column called "Display?". Do your testimonials say "Yes"?

  6. zucci2
    Member
    Posted 10 months ago #

    Thank you for responding. Yes, this is just a single post demonstrating the author's books. It is within a subcategory (Books for Adults) of a parent category (Books). Not archived. All of my testimonials within my test group "1" are set to YES for display. I'm probably missing something simple, but I can't figure out what.

    I am using a number of plug-ins, one of which is Use Any Font which I am using to apply a different font to H1-H6 headings and H1-H6 a headings at the moment. I deactivated all of my plugins with one exception, One-Click Child Theme, which I am using to build the child theme with customizations for this site. Deactivation did not seem to help. This site does not currently use Askimet; it is deactivated.

  7. Jeff K
    Member
    Plugin Author

    Posted 10 months ago #

    Can you send me a screenshot of several pages?

    1. WP-Admin > Testimonials
    2. WP-Admin > Tesitmonials > The groups page
    3. WP-Admin > Edit post page where the shortcode is at.

    You can send them to kreitje {@} hitmyserver {.} com

    Thanks for providing the info on your plugins.

  8. zucci2
    Member
    Posted 10 months ago #

    No need... your request helped highlight that "simple" thing I had missed. I had neglected to assign the testimonials to the group I created. When I created the screenshot of the group as you requested, I noted that there were 0 testimonials in the group. It works great now.

    I so appreciate you asking me to do this! This will work wonderfully for my client.

  9. Jeff K
    Member
    Plugin Author

    Posted 10 months ago #

    No problem. I am glad to hear you figured out your issue.

    Jeff

Reply

You must log in to post.

About this Plugin

About this Topic