WordPress.org

Ready to get started?Download WordPress

Forums

WP eCommerce
[resolved] Shopping cart woes! (4 posts)

  1. justawebbie
    Member
    Posted 2 months ago #

    I upgraded to the newest wp-e-commerce Version 3.8.14.1 and gold cart Version 2.9.7.8 (clean install). I use the authorize.net to process my payments.

    My shopping cart stopped working I noticed there was no billingstate in my checkout form and the shipping same as billing was not populating and stopping the cart from processing.

    I took off the shipping same as billing and the cart worked but still is missing the billingstate in the billing section of the form. I would like to have the shipping same as billing working as well.

    What fixes are out there to help me solve these two issues?

    https://wordpress.org/plugins/wp-e-commerce/

  2. Mihai
    Member
    Plugin Author

    Posted 2 months ago #

    Make sure you have the billing field enabled on the checkout page.
    And try in hte default theme to make sure its working right.

    Could be theme related issues. Maybe you moved wpec theme files in your theme and they are now outdated.

    Mihai

  3. justawebbie
    Member
    Posted 2 months ago #

    I tried what you said still no luck in getting the billingstate to show on the checkout default form in the checkout tab in store settings.

    I have never moved any of the files from its default location when it installs.

    Here is image of what my checkout form looks like

  4. Mihai
    Member
    Plugin Author

    Posted 2 months ago #

    You seem to be missing the billing state field in there.
    You will have to do a hard fields reset.

    Open your database manage (phpmyadmin maybe)
    Find the table: wpsc_checkout_forms (with your prefix infront ofcourse)
    Select it, then Click Operations.
    On the bottom right of that page you have: Empty the table (TRUNCATE) in red font.

    Do that action. Now your table should have no records at all.
    Now go back to your store, disable WP eCommerce and activate it back again.

    Now the fields should be fully restored.

Reply

You must log in to post.

About this Plugin

About this Topic