WordPress.org

Ready to get started?Download WordPress

Forums

WP eCommerce
[resolved] Shopping Cart Widget just shows "Loading..." (9 posts)

  1. PaulCutcliffe
    Member
    Posted 1 year ago #

    Store URL: http://www.MorePleasure.co.uk
    WordPress version: 3.5.1
    WP e-Commerce version: 3.8.11.1
    Gold Cart version: 2.9.7
    Theme: Artisteer Generated Custom Theme

    I did this: I upgraded WP-Ecommerce to the latest version this morning.

    I expected WP e-Commerce to do this: I expected the shopping cart widget to display correctly, as it did previously.

    Instead it did this: Instead, it just displays "Loading...". When you add something to the cart, it displays correctly until you switch pages or reload the current page, then it goes back to displaying "Loading..."

    http://wordpress.org/extend/plugins/wp-e-commerce/

  2. Justin Sainton
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Paul,

    I'd be happy to help you investigate this issue - shoot me an email at justinsainton@gmail.com and we'll go from there.

    Thanks!

  3. kmg454
    Member
    Posted 1 year ago #

    Same problem here with MIO theme

  4. Justin Sainton
    Member
    Plugin Author

    Posted 1 year ago #

    kmg454 - if you'd like to email me a link to your website, I'd be happy to see what the issue might be.

  5. kmg454
    Member
    Posted 1 year ago #

    The issue was a compatbility problem with WP e-commerce 3.8.11.1 and the MIO theme. Interactive pixels has updated the theme and everything is working fine now.

  6. PaulCutcliffe
    Member
    Posted 1 year ago #

    Thanks Justin, although I've now realised it was because of the caching plugin I was using - WP Super Cache. If I disable the caching plugin, the widget displays fine. :-)

    I guess WP-Ecommerce sites aren't ideal for use with caching?

  7. Justin Sainton
    Member
    Plugin Author

    Posted 1 year ago #

    E-Commerce and Caching in general is a mix of art and science - we do our best, but we're always trying to improve here. Any actionable bugs and issues should be reported on GitHub, we'd love the experience and general compatibility to be as awesome as possible.

  8. BobbySlingShot
    Member
    Posted 1 year ago #

    Hi guys,

    Having the same problem...

    @Justin - Did you find a solution for this that you can share?

    Update: After reading the Github post regarding the cache, it seems to be a complex problem to fix.

    If by any change there's a viable solution for this, it would be great to know.

    Thanks a lot!

    Regards,

    Andre

  9. PaulCutcliffe
    Member
    Posted 1 year ago #

    BobbySlingShot - I just disabled caching. Luckily I ruin a dedicated server that performs okay, so it's not too much of an issue for me.

    Update: Actually, whilst I have been known to ruin servers before, I actually meant that I 'run' a dedicated server, rather than ruin one. :-)

    (Could just have corrected my typo, but since it actually me me snigger, I thought I'd do it this way!)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic