WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
Shopping Cart Error (6 posts)

  1. C G
    Member
    Posted 1 year ago #

    Hello,

    I have about 60 products and each one has several variations (colors).

    Everything was working fine up until today when I was doing a test run and kept getting the following error(s) in my shopping cart:

    Product # is missing dimensions. Aborting.
    Product # is missing dimensions. Aborting.

    I don't know what this means and I'm not sure where to begin to address this issue.

    Please advise.

    http://wordpress.org/extend/plugins/woocommerce/

  2. guillame
    Member
    Posted 1 year ago #

    I have only one product and i am getting same error
    and have exhausted looking at all the settings

    Bill

  3. Roy
    Member
    Posted 1 year ago #

    I am not sure what is wrong and I am just guessing here but worth a shot. It would seem to me you're using a shipping method that requires a product to have dimensions set for it to be valid.

    To test this theory, turn off your shipping option and see if the error goes away. If it isn't shipping related then I am sorry, that is the only thing I can think of right now.

  4. holley2583
    Member
    Posted 10 months ago #

    This is happening to me now...have no idea for how long because i have'nt done a run through in a bit. I see there is no answer here that works as the shipping idea from splashingpixels.com did not fix the issue. The dimension options is on the Woo/catalog page and i've unchecked all the dimensions and weight options, but this error continues. It would be nice if somebody would share an answer... I'm going to start checking all my plugins and if I find the answer, i will share.

  5. lahirusn
    Member
    Posted 10 months ago #

    If u use UPS/ UPSP pluging for shopping cart, make sure u disable debug mode in woocommerce -> settings -> shipping -> ups :D

  6. holley2583
    Member
    Posted 9 months ago #

    I figured it out...depending on the USPS Plugin API, your theme may or may not require dimensions being set. Mine does not require dimensions set so to fix the error simply go to Woo, shipping, USPS, and click on API debug then save. Go back and test your cart to see if the error is gone. If not, you may have a theme that the USPS plugin API requires dimensions.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic