WordPress.org

Ready to get started?Download WordPress

Forums

Fedmich's Facebook Open Graph Meta
[resolved] Sharing Posts on Facebook with Multiple Images (8 posts)

  1. TheGG
    Member
    Posted 1 year ago #

    Hi Fedmich!

    For some reason (even before I installed this plugin) I was able to get the correct thumbnails to show up on Facebook... BUT only when I had a single picture in a post.

    My issue is with posts that have multiple images (examples below). I do get some images to show up... but usually, none are the Featured Image that I've set in my post:

    Example 1 (Multiple Pics in Post)

    http://www.glamorganicgoddess.com/safe-sunscreen-guide-best-natural-organic-sun-protection/

    Example 2 (Multiple Pics in post)

    http://www.glamorganicgoddess.com/natural-beauty-travel-essentials/

    When I installed this Plugin, nothing changed when I tried to share them on FB :/

    Please help!

    Thanks!
    Danielle :)

    http://wordpress.org/extend/plugins/facebook-and-digg-thumbnail-generator/

  2. fedmich
    Member
    Plugin Author

    Posted 1 year ago #

    Hello Danielle,

    Thank you for using the plugin and for reporting your issue in here.

    When I looked at your site.
    FB says that it seems that you have "More Than One OG URL Specified:"
    https://developers.facebook.com/tools/debug/og/object?q=http%3A%2F%2Fwww.glamorganicgoddess.com%2Fsafe-sunscreen-guide-best-natural-organic-sun-protection%2F

    The other meta tag is being generated by Yoast SEO, which is fine.

    What you could do to fix this is
    1. go to the option of my plugin
    settings / fb thumbnail
    2. uncheck "Add Meta og:url tag"
    3. Clear your Cache, since you are using Quick Cache

    Let me know how it goes later on.

  3. TheGG
    Member
    Posted 1 year ago #

    Hey Fedmich!

    Ok, I did what you said... cleared everything + waited a little while... but still no changes when I try to post on FB w/ multiple image posts :/

    Ugh! I'm beyond frustrated with this situation w/ Facebook! I've been researching + trying to figure this out for months now!

    Thanks! :)

  4. fedmich
    Member
    Plugin Author

    Posted 1 year ago #

    Hello,

    Great. the meta og:url is fixed.
    Now at least 3 photos shows up.
    http://i.imgur.com/hyX5n8b.png

    But facebook says other error.
    Provided og:image is not big enough. Please use an image that's at least 200x200 px. Image 'http://www.glamorganicgoddess.com/wp-content/uploads/2013/06/kids-sunscreen-lotion-spf30-badger.png' will be used instead.

    ---
    I think Facebook is just being strict on the image size to use.

    If you want to "force" a specific thumbnail to be used.
    1. edit that post
    2. go to custom fields
    3. make a new field, if its not there yet.
    thumbnail and then add url of photo in the value.
    4. save the post
    5. clear cache
    6. grab coffee, wait a bit for few mins
    7. check fb again

  5. TheGG
    Member
    Posted 1 year ago #

    Yeah, those same 3 (random) photos were showing up before I even installed this plugin... I need the "Featured Image" I've set up in the WP post to show up as an option on FB.

    The image size for this particular pic is 605 × 300. It seems to say that's the issue (og:image is not big enough) no matter what the image size is on all my posts with multiple photos.

    I just did what you said... I'll update in a little while.

    Thanks! :)

  6. TheGG
    Member
    Posted 1 year ago #

    Ok, no change! :/

  7. fedmich
    Member
    Plugin Author

    Posted 7 months ago #

    Hello,
    Just wanted to follow up on this.

    I suppose the issue on your site is now fix right?
    Let me close this thread then :)

    Thanks again for using the plugin

  8. TheGG
    Member
    Posted 7 months ago #

    Thanks! :)

Topic Closed

This topic has been closed to new replies.