WordPress.org

Ready to get started?Download WordPress

Forums

Sharedaddy
Sharedaddy Corrupts RSS Feed (13 posts)

  1. P. Chandra
    Member
    Posted 3 years ago #

    I used your amazing plugin, works very well. But was surprised to see it corrupted our feed and made it unusable. So we were forced to disable the plugin. Please fix this issue.

  2. John Godley
    Member
    Plugin Author

    Posted 3 years ago #

    How did it corrupt your feed?

  3. P. Chandra
    Member
    Posted 3 years ago #

    The wordpress feed failed to load. As soon as I disabled the plugin, all was well.

  4. John Godley
    Member
    Plugin Author

    Posted 3 years ago #

    How did it corrupt your feed? Are there errors? Do you have an example I can look at?

  5. P. Chandra
    Member
    Posted 3 years ago #

    The feed fails to load. I don't know how it corrupts it. All is fine when I disable the plugin.
    http://www.quickonlinetips.com/archives/feed

  6. John Godley
    Member
    Plugin Author

    Posted 3 years ago #

    Have you tried disabling other plugins and keeping Sharedaddy enabled to see if that affects anything? I've not seen any problems with feeds when the plugin is installed.

  7. Eduardo Larequi
    Member
    Posted 3 years ago #

    I've made some tests with Sharedaddy in a multisite blog platform. When Sharedaddy is activated, RSS feed works well with some themes, but with other the RSS feed is cut.

    Look at these two blogs (test blogs):

    1. http://irati.pnte.cfnavarra.es/multiblog/utnt3/. Sharedaddy is set so that buttons appear only in post and pages. The RSS feed is validated, in spite of some errors, by Feed Validator. This blog uses Arjuna X 1.3.9 theme.

    2. http://irati.pnte.cfnavarra.es/multiblog/utnt3/. The same settings for Sharedaddy, but in this case the RSS feed is not validated. This blog uses Graphene 1.0.9.3 theme.

    As they belong to a multisite blog, the two blogs share the same bunch of plugins.

    Any idea?

  8. Eduardo Larequi
    Member
    Posted 3 years ago #

    There was an error in my previous post. The URL of the second blog is this: http://irati.pnte.cfnavarra.es/multiblog/elarequi/ (Graphene theme, version 1.0.9.3).

  9. John Godley
    Member
    Plugin Author

    Posted 3 years ago #

    I'm not seeing any feed errors with the second feed. Sharedaddy should not modify your RSS at all.

  10. Eduardo Larequi
    Member
    Posted 3 years ago #

    Forgive my insistence, John.

    Look at this blog, please: http://irati.pnte.cfnavarra.es/multiblog/utnt3/ (a test blog). When Sharedaddy is enabled (now it is) and no post has its excerpt, Feed Validator says:

    Sorry
    This feed does not validate.
    line 30, column 2: XML parsing error: <unknown>:30:24: unclosed CDATA section

    If Sharedady is disabled, Feed Validator validates the feed.

    I think that this problem has something to do with excerpts. If I fill the excerpts of all the posts, feed validator says the feed is correct. But if any of the posts lacks its excerpt, Feed Validator doesn't validate. To check this assumption, I've made another test with two posts with excerpt and the first one ("Hola, mundo"), without it. In this case, Feed Validator says:

    Sorry
    This feed does not validate.
    line 60, column 2: XML parsing error: <unknown>:60:24: unclosed CDATA section

    It's obvious that something is broken in the feed. I'm not programmer at all, but I think that this problem has something to do with Sharedaddy, because it occurs with other themes and other blogs, in different circumstances.

  11. John Godley
    Member
    Plugin Author

    Posted 3 years ago #

    Sorry, I still can't reproduce this, with or without excerpts. Do you have any plugins running that may affect this?

  12. Eduardo Larequi
    Member
    Posted 3 years ago #

    There are many plugins (it's a multisite installation), not only in /plugins folder, but also in /mu-plugins.

    Here you have the list of plugins in /plugins which are activated site-wide and so can affect my test blog: Akismet, Cimy Swift SMTP, Contact Form 7, Lightbox 2, Sidebar Login, Simpler iPaper, SlideShare, Subscribe To Comments, Viper's Video Quicktags, WordPress.com Custom CSS, WordPress Importer, WP Calameo, WP Issuu.

    I've deactivated all of them, one by one, and then I've checked the feed, as many times as necessary. The problem still happens.

    I'll try to check plugins in mu-plugins, but it's a difficult task.

    Anyway, thanks for your help and interest, John. I'll come back on this issue if I discover anything.

  13. Eduardo Larequi
    Member
    Posted 3 years ago #

    I've forgotten to say that in a new test blog, with Sharedaddy and Akismet activated and Arjuna X theme, there's no problem with the feed.

    Compare:

    http://irati.pnte.cfnavarra.es/multiblog/utnt3/ (bad feed).
    http://www.elarequi.com/pruebas2/ (valid feed).

    So, it seems probable that some plugin in my multisite installation is the culprit. But, which one?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags