WordPress.org

Ready to get started?Download WordPress

Forums

shared media library, stuff not working since moving to MU (3 posts)

  1. StringerB
    Member
    Posted 1 year ago #

    Hello,

    I was wondering if I could have a shared media library for all sites running in the Multisite network? I only found this article so far: http://blog.channeleaton.com/sharing-media-libraries-across-network-sites

    Otherwise, would it be easier to set up a specific FTP folder where all media are uploaded manually and then to use the URL field to insert media in posts?

    Also, I recently set up the multisite network, everything works fine so far except for 2 things:
    -WP does not take into account the custom sizes I have set up for pictures in the Settings > Media panel. (=my main problem)
    -Jquery tabs no longer work correctly. The tab's content disappears when clicking on the corresponding tab. Other Jquery elements work just fine and use the same js/css files... And it still works on the monosite install.

  2. Generally speaking, no. Media libraries are per site. Data is per-site, users and themes and plugins are network wide.

    The only way I know is via this plugin: http://wordpress.org/extend/plugins/network-shared-media/

    It should work, but I've neevr used it.

  3. StringerB
    Member
    Posted 1 year ago #

    Hey! Thank you for your reply.

    I tried the Network Shared Media plugin yesterday and it works great I must say. However it only works for inserting medias in posts & pages, but you cannot use it to set a featured image.

    Nonetheless, this plugin can be very useful.

Topic Closed

This topic has been closed to new replies.

About this Topic