WordPress.org

Ready to get started?Download WordPress

Forums

Social Media Feather
[resolved] Share link not appearing for Home Page (8 posts)

  1. theotherplatt
    Member
    Posted 9 months ago #

    Hello, I have been working with your plugin and want to compliment you for the ease of use and captivating look. Will definitely look into buying the pro version once the site is rolling and we expand our social media presence.

    I am experiencing an issue with the plugin and am hoping that you could help with it. I am using Responsive theme (the free version) and while the social media icons work fine in other pages, when it comes to the home page they fail to load the actual link to share.

    I placed the plugin in a widget (top of page).

    I contacted the creators of the theme and they found a couple more bugs, like the Twitter link adding an extra ../wordpress at the end of the URL. They (CyberChimps) would like to cooperate with you in looking for a solution.

    I hope you can help me fix this?

    The site is not online yet, but you can look it up at http://www.nyensembleclasses.com/wordpress

    Thanks,
    Platt

    http://wordpress.org/plugins/social-media-feather/

  2. Synved
    Member
    Plugin Author

    Posted 9 months ago #

    Try and turn on "Share Full URL" under Settings -> "Social Media"

    Alternatively if the widget is only shown on the homepage you could use a text widget with a shortcode and the static URL:
    [feather_share url="http://www.nyensembleclasses.com/wordpress/"]

  3. theotherplatt
    Member
    Posted 9 months ago #

    Hi Synved, thank you for the reply. The first option didn't work out.

    The shortcode does the trick and while this way I can only share the home page, I can live with that. My problem is that now the icons are a lot bigger than I would like them to be. How can I fix this and make them the same size of the ones previously placed? (I am currently keeping both for you to see...)

    Thanks!
    Platt

  4. theotherplatt
    Member
    Posted 9 months ago #

    My bad. I found the option to resize the icons.

    Thank you for your support. At this point, is there any chance to get the widget work in all its features instead of a static URL?

    Thanks!
    Platt

  5. Ulrich
    Member
    Posted 8 months ago #

    Hi Synved,

    Is there any reason why the social media icons do not work well on a custom front page?
    http://cyberchimps.com/forum-topic/home-page-wont-be-shared-in-social-media/

    @theotherplatt You can use a plugin like this where you use the static link url just for the front page and for the rest of the pages a normal shortcode.
    http://wordpress.org/plugins/woosidebars/

  6. Synved
    Member
    Plugin Author

    Posted 8 months ago #

    It's not caused by the custom front page but by the custom home URL derived from what I think might be a subdir install. I'm not sure if it's generic to subdir installs but It seems the site is configured to have the "/wordpress" URI returned as the home_url() which I'm assuming is some kind of custom configuration in General preferences.

    I'm working on some type of workaround for this kind of setup by analyzing/parsing the request URI and comparing against home_url(). I have to investigate this more though before I come to any conclusions (probably will be done over the weekend).

  7. theotherplatt
    Member
    Posted 8 months ago #

    Hi, I actually made a regular install of wordpress without making any specific changes to the general preferences. I don't know if something happened automatically, though.

    Once I am done designing the site I will move the home page to the root (but not the wordpress folder).

    Thanks again for your support!
    Platt

  8. Synved
    Member
    Plugin Author

    Posted 8 months ago #

    This should be fixed in the latest version, 1.4.3.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.