WordPress.org

Ready to get started?Download WordPress

Forums

Social Linkz
[resolved] Share Counter are all with ZERO value (20 posts)

  1. ucramos
    Member
    Posted 1 year ago #

    Since some time now, my share counter are all at ZERO. they had the value of shares but from some time now they show ZERO. I´m not shure if this happened after i updated to wordpress 3.5 of after a plugin upgrade.

    I have a plugin on the admin page called WP Social Stats the has a similar system to this plugin. I show the amount of shares off all posts on the website. And this plugin is showing the correct amount of shares, so i think that this isn´t any problem of access permission to external links.

    Does anyone have this problem?

    http://wordpress.org/extend/plugins/social-linkz/

  2. Sed Lex
    Member
    Plugin Author

    Posted 1 year ago #

    What is the URL of your website so that I could look for the reasons ?

  3. ucramos
    Member
    Posted 1 year ago #

    http://helenaorge.sytes.net:8000/

    Thanks for the quick response.

    I even uninstalled it and reinstalled it to test and it´s still showing ZEROS,

  4. Sed Lex
    Member
    Plugin Author

    Posted 1 year ago #

    And just for my information how did you update the plugin ? With FTP or with the embedded tool of WordPress ?
    My first guess is that either there is a database issue (not created) or a JavaScript bug ...
    Could you check that a database wp_pluginSL_sociallinkz is created ?

  5. ucramos
    Member
    Posted 1 year ago #

    i used the upgrade system of wordpress.

    I don´t have that table created. I uninstalled the plugin before posting this topic and did a new install, but that table wasn´t created.

  6. Sed Lex
    Member
    Plugin Author

    Posted 1 year ago #

    Try executing such SLQ command to create the table
    CREATE TABLE wp_pluginSL_sociallinkz (id mediumint(9) NOT NULL AUTO_INCREMENT, id_post mediumint(9) NOT NULL, counters MEDIUMTEXT DEFAULT '', date_maj DATETIME, UNIQUE KEY id (id)) DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci ;

  7. ucramos
    Member
    Posted 1 year ago #

    I get this error message:

    #1101 - BLOB/TEXT column 'counters' can't have a default value

  8. Sed Lex
    Member
    Plugin Author

    Posted 1 year ago #

    CREATE TABLE wp_pluginSL_sociallinkz (id mediumint(9) NOT NULL AUTO_INCREMENT, id_post mediumint(9) NOT NULL, counters MEDIUMTEXT, date_maj DATETIME, UNIQUE KEY id (id)) DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci ;

  9. ucramos
    Member
    Posted 1 year ago #

    I used

    CREATE TABLE wp_pluginSL_sociallinkz (id mediumint(9) NOT NULL AUTO_INCREMENT, id_post mediumint(9) NOT NULL, counters MEDIUMTEXT , date_maj DATETIME, UNIQUE KEY id (id)) DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci ;

    The table is created but i still have the fields at ZERO

  10. Sed Lex
    Member
    Plugin Author

    Posted 1 year ago #

    You have no entry in the database ?

  11. ucramos
    Member
    Posted 1 year ago #

    http://helenaorge.sytes.net:8000/?p=100 has 49 shares
    http://helenaorge.sytes.net:8000/?p=110 has 249 shares

    These are some examples. Not all of the links have shares. But these 2 have shares and on the plugin they appear with ZERO shares

  12. ucramos
    Member
    Posted 1 year ago #

    1 100 {"twitter":0,"facebook":0,"google+":0,"stumbleupon... 2013-01-18 14:12:33
    2 400 {"twitter":0,"facebook":0,"google+":0,"stumbleupon... 2013-01-18 14:12:41
    3 1000 {"twitter":0,"facebook":0,"google+":0,"stumbleupon... 2013-01-18 14:14:14
    4 210 {"twitter":0,"facebook":0,"google+":0,"stumbleupon... 2013-01-18 14:16:20
    5 220 {"twitter":0,"facebook":0,"google+":0,"stumbleupon... 2013-01-18 14:16:29

    I have these records on the table

  13. ucramos
    Member
    Posted 1 year ago #

    This is running on a Windows Server 2012 Datacenter with IIS 8
    MySQL: 5.5.29
    Engine: MyISAM
    PHP: 5.4.11
    PHP Memory: 512M

  14. Sed Lex
    Member
    Plugin Author

    Posted 1 year ago #

    Only on facebook ?
    If so, please contact me through the feedback tab of the plugin and I will sent you a beta version back

  15. ucramos
    Member
    Posted 1 year ago #

    I only have shares on facebook, so i don´t know if this is just a facebook problem or if it affects other services.

    Thank you so much for your support.

  16. Sed Lex
    Member
    Plugin Author

    Posted 1 year ago #

    No it is not a facebook problem.
    Perhaps my plugin have an issue with the url of your site (including the port number) => I have to sent you a debug version

  17. ucramos
    Member
    Posted 1 year ago #

    but the plugin was working perfectly before. The only problem was that i updated WordPress and the plugins at the same time.. so i don´t know when did the problem started.

  18. ucramos
    Member
    Posted 1 year ago #

    ok .. know i have to get the mail() working so i can send you a feedback on the plugin page :)

  19. Sed Lex
    Member
    Plugin Author

    Posted 1 year ago #

    my email is in the header of the main file of the plgin if you have difficulties

  20. ucramos
    Member
    Posted 1 year ago #

    Resolved

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.