WordPress.org

Ready to get started?Download WordPress

Forums

Sharing buttons shortcode for Jetpack
[resolved] Share buttons do not display using the shortcode (7 posts)

  1. bradclarkuk
    Member
    Posted 1 year ago #

    Hello,

    I have placed the shortcode on my page however the search buttons do not appear.

    Please see here - http://brokenvault.com/portfolio/ben-rix/

    The middle section - share this artist - is where the shortcode is placed.

    http://wordpress.org/extend/plugins/jetpack-sharing-butttons-shortcode/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Could you go to Pages > All Pages in your dashboard, click on that page, and make sure the sharing checkbox is checked for that page?

    Let me know if it helps.

  3. julie
    Member
    Posted 10 months ago #

    I am having this same problem. I put the shortcode in the template for the desired page, then made sure that I had a checkmark in the sharing checkbox in the page as per your instructions. It isn't working.

  4. julie
    Member
    Posted 10 months ago #

    I have the shortcode executing this way in my template file, btw:

    echo do_shortcode('[jpshare]');

    Thank you for any help you can give me!

  5. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    @julie Instead of using do_shortcode, and if you do not use the shortcode itself in your posts, you can delete my plugin and use <?php eho sharing_display(); ?> to display the sharing buttons anywhere within a loop in your template files.

    Of course, Jetpack has to be activated, and the Sharing module should be active and configured under Settings > Sharing in your dashboard.

  6. julie
    Member
    Posted 10 months ago #

    Jeremy,
    Thanks for the quick and helpful answer. I tried what you suggested:

    1. Disabled your plug-in
    2. Added <?php echo sharing_display(); ?> inside my loop -- just before the content.
    3. I verified that sharing was on.
    4. Still no icons.

    I currently do not have a checkmark next to pages because I do not want the share icons to show on all of them -- only a few select pages. So, is that what the problem is -- I need to have a checkmark next to pages?

    If so, do you know a good way to get these share icons to appear on only selected pages?

    Thanks again,
    Julie

  7. julie
    Member
    Posted 10 months ago #

    Oh, never mind. I'm stupid. I just unchecked the sharing box in the individual pages that I do not want to have it show up -- duh! Very stupid of me. Thanks again for your help!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic