WordPress.org

Ready to get started?Download WordPress

Forums

Share and Follow
Share and Follow not getting post link (21 posts)

  1. thesufi
    Member
    Posted 2 years ago #

    After I updated my Share and Follow version to most latest version, I am facing an error. No matter from which page someone try to share any post/page in any social site, it only gets homepage url. It is not getting post url.

    How could I fix it? It was working properly before the update.

    http://wordpress.org/extend/plugins/share-and-follow/

  2. givemedap
    Member
    Posted 2 years ago #

    I think I have the same problem as you. Although i have had this issue prior to the update. Every time someone tries to share a post on Facebook, it only shares the homepage url. Did you happen to find a fix?

  3. thesufi
    Member
    Posted 2 years ago #

    No, I did not get any fix yet. I have posted all the social buttons manually in the theme files.

  4. andykillen
    Member
    Plugin Author

    Posted 2 years ago #

    try first a different theme. if it works it's your theme that is at fault.
    2nd try disabling all plugins and just using share and follow and see if it works. if it does then some other plugin is at fault.

    I get the feeling that it is your theme or plugin choices that are at fault as it works for fifty thousand other installs, including my many test installations

  5. thesufi
    Member
    Posted 2 years ago #

    No, this is not for any theme or for some other plugin. For some reason it is not getting the current page URI. So it is taking main URL only.

  6. andykillen
    Member
    Plugin Author

    Posted 2 years ago #

    So you tried another theme and disabling all other plugins?

  7. thesufi
    Member
    Posted 2 years ago #

    Yes indeed.

  8. andykillen
    Member
    Plugin Author

    Posted 2 years ago #

    What theme and plugins do you have installed? what is your site? what theme did you try?

  9. thesufi
    Member
    Posted 2 years ago #

    I am using a custom theme, and with:
    Google XML sitemap
    W3 Total Cache Plugin.
    All in One SEO Pack
    and
    WP-Paginate

  10. andykillen
    Member
    Plugin Author

    Posted 2 years ago #

    and what theme did you try? I cannot setup a test if you do not give me the wanted information.

  11. andykillen
    Member
    Plugin Author

    Posted 2 years ago #

    also what is your URL. as requested before

  12. thesufi
    Member
    Posted 2 years ago #

    Actually I am using a custom theme. Here is the site URL: http://www.ilike2like.com
    I have tried changing the theme to Colorwave from themeforest. But it did not fix. I tried deactivating all plugins, it also did not work.
    I am currently running the same version of Share and Follow plugin in another site with Colorwave theme. It is working there.

  13. andykillen
    Member
    Plugin Author

    Posted 2 years ago #

    I see no evidence of share and follow plugin on that site.

  14. thesufi
    Member
    Posted 2 years ago #

    Yes, I have removed it since it is not working.

  15. andykillen
    Member
    Plugin Author

    Posted 2 years ago #

    OK, I give up. you won't let me test it and my your own admission it works on other locations. This clearly points to it being a problem at your end. As you are I expect the hosting company I leave it up to you to sort it out.

  16. thesufi
    Member
    Posted 2 years ago #

    No problem and thanks for your time. I actually no more need solution for this.
    I thought it's a common error, so need some tweaking. Later I had found it is happening only in my site. So planned to solved myself. I went through your codes, but no way I was able to fix it. So decided to put some custom sharing options in my site. I am currently working on it.
    I did not understand your last line though "As you are I expect the hosting company I leave it up to you to sort it out. ".

  17. andykillen
    Member
    Plugin Author

    Posted 2 years ago #

    thanks for reminding me why I don't offer support through this forum any more. It is a complete waste of my time. Shame really when I offer a free plugin and try to give you help I get the run-around.

    Even after stating that 50,000 people have installed this version and there are only 2 people that have problems, that it might be at your end. You still persisted to think that it must be the plugin that is at fault.

    On top of that I gave you clear instructions that you obviously did not follow as it would have taken you more than 4 minutes to change theme, clear the cache and try again and then reply, let alone disable all plugins and try again. In fact you did nothing today, as the plugin was not even installed, and certainly not the latest version of the plugin. Why did you persist with questions and problems when your already sure that it is something that is based on your hosting situation/code????? It beggars belief.

    Yes I expect that DCT ltd. is who you might be as you are willing to change the code of the theme. DCT is a company that offers hosting from their website. what is so hard to understand about expecting the hosting company to resolve their own problems?

  18. thesufi
    Member
    Posted 2 years ago #

    Seems like you are angry!
    You created a nice plugin and thanks for that. I never said that this is an error of the plugin. I just started this thread to check if anyone else having the same problem or not, or someone even might have some solution for it.
    The instructions you gave me, I followed them since I faced the problem. I don't the actual reason of the problem. But tried to solve it myself. As I failed, was looking for help, if anyone else having this problem or not. Then found the problem is only in my site. I strongly believe problem is not in my hosting. As I am running few more sites with same version of your plugin in the same hosting. They are working perfectly.
    Yes plugin is not installed in my site, since it is not working for this site, I had deleted it.
    You probably did not check the posting date of this thread. I had posted it here 1 week ago. As there were no reply or no other same problem, and also after looking through your codes, I did not get any error. Also tried your instructions 7 days ago (which you have just provided). As it did not work, so just implementing my own way to work with my theme.
    I never said that your plugin has any error.
    Thanks.

  19. andykillen
    Member
    Plugin Author

    Posted 2 years ago #

    quite simply yes I am angry at you wasting my time. by not answering the questions asked and having to have them repeated, by not following instructions, by not even having the plugin installed. All of these things add up to making me angry as your just wasting my time......

  20. thesufi
    Member
    Posted 2 years ago #

    hahahaha... actually actually you wasted your time by being angry. I ignored you first time, because I though some guy like me giving me some suggestions, which I have already done. Later I have found that you are the developer of the plugin, and then I have explained everything.
    You no need to waste your time anymore, and I am also not interested to waste both of our time to find out the error, which I think only I am having, as my plan is changed.
    And thanks man, for this plugin. It saves lots of people's time.
    Cheers.

  21. Vakantie Ameland
    Member
    Posted 2 years ago #

    I have to agree on this error report.

    In version 1.60.7 the parameters in the url on the facebook share buttons ?u=http://blaaah&t=blaahtext were not empty. They are filled. Now in the 1.70.2 version there are only empty parameters u=&t=

    The same for all the other share links like delicious url=&title= or Linkedin url=&title=

    When I use the 1.70.2 this happens. When I go back and use the old version 1.60.7 the parameters are correct and filled.

    Something must have changed in the plugin version 1.70.2 that causes the parameters to be empty. The theme or other plugins or whatever conditions did not change.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic