WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Shardb] - blog 1 giving 404 errors - posts not showing in panel (4 posts)

  1. jfarruguia
    Member
    Posted 2 years ago #

    I've just installed sharedb on a site with 7500+ blogs on 16Dbs. Installation went perfectly fine, and all seemed OK at first, right after uploading db.php.

    However there seems to be an issue with some pages, it seems on blog 1 only (which is in a separate DB - xxx_home0), most pages/posts are not being displayed at all in the site, some pages are giving a 404 and posts are just not showing up (empty). Also, the posts section and the pages section in the admin panel is completely empty after the migration (which is not supposed to be so), although they do exist in the database (i believe i've stumbled across them in the home db). I am also using WPML Multilanguage - if it helps.

    I downloaded the installation ebook of Ron/Andrea, and followed every phrase, however i could not get it to work.

    The plugin works fantastically as the whole site is much more responsive, however this issue with pages/posts not being available in the site admin is killing me!

    Please help!

  2. Ron Rennick
    MultiSite Guru
    Posted 2 years ago #

    Do you know if WPML is compatible with Multi DB? If you remove/deactivate the WPML, do you still get the 404s, etc.

    One alternative that you could try is moving the main site tables to the global DB if your network was created after WP 3.0 or database c if it's an upgraded MU install.

  3. jfarruguia
    Member
    Posted 2 years ago #

    Hi Ron :)

    Firstly, good job on the shardb plugin, you've done a magnificent job!

    I've scripted out all db tables on the home db and created them in global database, however to no avail. Once it did not work, I tried switching 'off' the shardb by removing db.php, but something weird happened, on the plugins page on the site admin, i keep getting a whole bunch of errors like the below:

    Warning: constant() [function.constant]: Couldn't find constant in /home/mpc/domains/newjerseyscratchcard.com/public_html/wp-admin/includes/class-wp-plugins-list-table.php on line 346

    AND

    Inactive: Requires define('', true); in wp-config.php.

    .. so now im left with two issues :(

    I dont recall doing any other changes apart from extracting the tables from one db to another, and when switching back, i switched back the db config to point to the old database. Another issue is that the DB contains over 80K tables, and to the migration process will take a few
    days if i were to run it again.

    I am completely lost

    Your Sincerely,
    Justin Farrugia

  4. Ron Rennick
    MultiSite Guru
    Posted 2 years ago #

    Yeah, 80K tables would not be much fun to migrate again.

    Double check your wp-config to see that you didn't comment out something extra.

    The way shardb is designed you should be able to add/remove db.php to switch between the old single DB & the new DBs.

    When you copied the main site tables to the global DB, did you remove the $shardb_enable_home from your db-settings.php?

Topic Closed

This topic has been closed to new replies.

About this Topic