WordPress.org

Ready to get started?Download WordPress

Forums

Shadowbox JS
Shadowbox JS not working with get_the_content function. (6 posts)

  1. manaraga
    Member
    Posted 1 year ago #

    Hi! I found what shadowbox JS not working with get_the_content function. If i change it to the the_content its fork fine. I think its needed an a special hook or filter to apply adding rel="shadowbox" to the image links if used get_the_content.

    Can you help me?

    I should use get_the_content couse its pushed in to the trancient cache.

    http://wordpress.org/extend/plugins/shadowbox-js/

  2. Matt Martz
    Member
    Plugin Author

    Posted 1 year ago #

    The plugin utilizes the 'the_content' filter. So you can run that filter on the output of get_the_content() such as:

    apply_filters('the_content', get_the_content())

  3. lynnpd
    Member
    Posted 1 year ago #

    I'm using a theme by Elegant Themes called "The Source." I've installed the Shadowbox JS in WordPress for the site, but it's not working. Have you heard of any compatibility problems with this theme or any themes at Elegant Themes?

    If not, is there some set up other than installing the plugin that needs to be done to get it to work. I have it on three other sites at different domains and it works fine, but not on this theme or this domain or web host.

    Thanks.

  4. lynnpd
    Member
    Posted 1 year ago #

    What does it mean in the installation: Visit the settings page in the Admin at Settings -> Shadowbox JS and install the required dependencies

    What are "required dependencies?"

  5. johnflufin
    Member
    Posted 1 year ago #

    lynnpd - I'm not positive but I think that's referring to the actual Shadowbox script files which were developed by someone other than the author of this plugin, hence the need to install them separately. After installing the SB JS plugin there should be a box with a link to download the "required dependencies" on the plugin settings page.

  6. johnflufin
    Member
    Posted 1 year ago #

    Matt - the_content is breaking the plugin too. See my post here

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic